Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

All of a sudden, I had the date and time on the menu bar of my 10.6 machine vanish. I tried turning it on in the "Preferences >> Date and Time" section but I'm not able to.

Anyone got similar problems/found a solution to this?

If there's any additional information I can provide you, please let me know. Thanks in advance!

share|improve this question
When you say "not able to" what do you mean? The checkmark appears enabled, so does it select itself? If so, open Console from the Utilities folder and examine the last few entries under "All Messages" when yo try enabling it again. – Christian L Dec 1 '11 at 3:08
If the screen image at the top of this page is correct, notice that the checkbox is NOT checked next to "Show date and time in menu bar" (topmost checkbox). That box needs to be checked. That said, I am not able to get the date to appear myself; just the time is visible. – user59809 Oct 18 '13 at 20:22
up vote 2 down vote accepted

It's possible located in your user /Users/yourShortNameHere/Library/Preferences is corrupted.

Close the System Preferences window. Move that plist out of its directory, and re-launch the System Preferences.

Feedback if it doesn't work.

share|improve this answer
Hmm, there was no such file in the first place. I tried creating an empty file with the name, still no results. – wheee Nov 28 '11 at 6:33
You need not create the property list as it is created and maintained by the Date and Time preference pane. The fact that the file isn't there is odd. Are you logged in as a user with Admin privilege? – Global nomad Nov 28 '11 at 9:22
Yes, there is only one user - the current one(admin) I've logged in as. – wheee Nov 28 '11 at 9:47
Since you're logged in as an admin, that rules out permission-related issues that prevents creation of the plist. Do you have a Time Machine backup (preferably the earliest Lion backup when it still works properly)? May be worth a try to recover both the Date and Time preference panel AND the plist I mentioned in the answer above. Revert and let us know if this works. – Global nomad Nov 28 '11 at 15:47
Yup, it did, thank you. – wheee Nov 29 '11 at 16:24

If the above suggestions doesn't work, I recommend you try creating a fresh new user and reboot/login from there to see if this fixes the issue. There might be a problem with your specific user.

Also what do you exactly mean by: "but I am not able to". What happens when you check the "show date and time" checkbox?

share|improve this answer

Maybe you can restore your permissions? You can find here how to do this. This will return your original permissions by factory settings. Maybe, the problem is caused by something you've done before.

Or you can try and reset your PRAM. It's not really the part which controls the time-management, but it does manage the disk-cache and some additional time-settings.

Maybe the problem will be solved after those two tips.

share|improve this answer

Try launching the menu extra “by hand”. It is located in /System/Library/CoreServices/Menu Extras/ Try double-clicking that file.

If that does not solve the problem, then launch the Console (in /Applications/Utilities/) and look for something like:

SystemUIServer[205] failed to instantiate and get the principal class of bundle: NSBundle </System/Library/CoreServices/Menu Extras/> (not yet loaded)

(anything that mentions actually — should be at the end of the log files)

share|improve this answer

In Finder, open the Go -> Go To Folder menu item. Copy and paste this into the window:

/System/Library/CoreServices/Menu Extras/

it should look like this:

enter image description here

Click 'Go'

Look for "" in that folder and double click on it.

Alternatively, if you are comfortable in the Terminal, use

open '/System/Library/CoreServices/Menu Extras/'
share|improve this answer

I had one thought that hasn't been covered. Your computer has a small battery on the motherboard that is supposed to last about 4-5 years. If this battery runs down, the date/time will not be stored. This is a long shot though, as I cannot remember the last time I had this problem - 8 years?

So, if the solutions above do not work, and especially the great suggestion to create a new user, the only recourse left (and it may be a good idea under the circumstances**), is to perform an clean reinstallation of your system.

I presume you have your 10.6.x disk. Make a clone (I like Carbon Copy Cloner) to an external drive, or a complete Time Machine backup.

1.Reinstall Snow Leopard. 2.Check / repair permissions as many times as necessary. 3.Perform Software Updates as many times as necessary. 4.Repeat step 2.

Let us know the outcome. Good luck.

** if there is something screwy with the date and time prefs, then other system functions may also be malfunctioning, and you don't want to end up with bad/missing data.

share|improve this answer
It may be helpful to me to know why this post was flamed. I was just trying to help. – David DelMonte Nov 28 '11 at 20:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.