Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

This is a new question related to a question I asked previously.

MacBook is sleeping despite being set to "never" sleep

Basically, the MacBook would sleep after 3 hours despite the preferences telling it to "never" sleep.

I fixed the original problem by deleting the Energy Saver plist file.

However, after two weeks, it broke again and the original problem came back. I have no doubt that I can just fix it by deleting the preference file again.

Obviously something external is botching up the Energy Saver preference file. I'm wondering if anyone can tell me how I can determine what could be causing this problem in the first place.

EDIT:

Trashing the Energy Saver plist file no longer fixes this issue. I've removed Caffeine and I'm out of ideas. I can't even effectively troubleshoot this since it takes three hours just to see if it will sleep or not. What else can I do? Where else can I look?

share|improve this question
    
Do you use any applications that manipulate sleep settings? Such as Caffeine or InsomniaX? –  Jason Salaz Nov 24 '11 at 22:38
    
@JasonSalaz, I have Caffeine installed but have not used it within the last few weeks, maybe not for a month or more. AFAIK, Caffeine only prevents "Display Sleep" and my issue is with System Sleep. You're thinking that Caffeine maybe is corrupting the plist file? –  Sparky Nov 25 '11 at 4:19
    
I don't imagine Caffeine is corrupting anything if you're not actually using it. It was just an idea that came to mind. FYI, Caffeine prevents any/all sleep, not just display sleep. –  Jason Salaz Nov 25 '11 at 11:15
    
@JasonSalaz, I trashed the prefs file again and updated Caffeine to the latest version. It went to sleep again last night though. I'm getting pretty frustrated with this. –  Sparky Nov 25 '11 at 16:54
add comment

1 Answer

up vote 2 down vote accepted

Perhaps you should try resetting the SMC, as described here: http://support.apple.com/kb/ht3964

share|improve this answer
    
I ended up deep cleaning all the caches as well as your suggestion of resetting the SMC. Last night, it finally stayed awake. –  Sparky Nov 29 '11 at 15:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.