Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've been trying to start eclipse IDE on my Mac for a while, I downloaded different versions and no one works.

I'm sorry if there is something I missed.

Here is the log:

!SESSION 2011-11-23 17:04:56.136
----------------------------------------------- eclipse.buildId=I20110613-1736 java.version=1.6.0_29 java.vendor=Apple
Inc. BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments:  -keyring /Users/apple1/.eclipse_keyring
-showlocation Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -keyring /Users/apple1/.eclipse_keyring -showlocation

!ENTRY org.eclipse.equinox.p2.core 4 0 2011-11-23 17:04:56.849
!MESSAGE Provisioning exception !STACK 1
org.eclipse.equinox.p2.core.ProvisionException: Unknown repository
type at
file:/Users/apple1/Downloads/eclipse%203/configuration/org.eclipse.osgi/bundles/81/data/listener_1925729951/.
    at
org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.fail(AbstractRepositoryManager.java:393)
    at
org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.doCreateRepository(AbstractRepositoryManager.java:282)
    at
org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.createRepository(MetadataRepositoryManager.java:41)
    at
org.eclipse.equinox.internal.provisional.p2.directorywatcher.RepositoryListener.initializeMetadataRepository(RepositoryListener.java:109)
    at
org.eclipse.equinox.internal.provisional.p2.directorywatcher.RepositoryListener.<init>(RepositoryListener.java:59)
    at
org.eclipse.equinox.internal.p2.reconciler.dropins.DropinsRepositoryListener.<init>(DropinsRepositoryListener.java:82)
    at
org.eclipse.equinox.internal.p2.reconciler.dropins.Activator.watchDropins(Activator.java:532)
    at
org.eclipse.equinox.internal.p2.reconciler.dropins.Activator.start(Activator.java:172)
    at
org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
    at java.security.AccessController.doPrivileged(Native Method)   at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
    at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
    at
org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
    at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:389)
    at
org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1130)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
    at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
!SUBENTRY 1 org.eclipse.equinox.p2.metadata.repository 4 1005
2011-11-23 17:04:56.850 !MESSAGE Unknown repository type at
file:/Users/apple1/Downloads/eclipse%203/configuration/org.eclipse.osgi/bundles/81/data/listener_1925729951/.

!ENTRY org.eclipse.equinox.p2.reconciler.dropins 4 0 2011-11-23
17:04:56.852 !MESSAGE FrameworkEvent ERROR !STACK 0
org.osgi.framework.BundleException: Exception in
org.eclipse.equinox.internal.p2.reconciler.dropins.Activator.start()
of bundle org.eclipse.equinox.p2.reconciler.dropins.    at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
    at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
    at
org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
    at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:389)
    at
org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1130)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
    at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
Caused by: java.lang.IllegalStateException: Could not create metadata
repository for:
file:/Users/apple1/Downloads/eclipse%203/configuration/org.eclipse.osgi/bundles/81/data/listener_1925729951/
    at
org.eclipse.equinox.internal.provisional.p2.directorywatcher.RepositoryListener.initializeMetadataRepository(RepositoryListener.java:112)
    at
org.eclipse.equinox.internal.provisional.p2.directorywatcher.RepositoryListener.<init>(RepositoryListener.java:59)
    at
org.eclipse.equinox.internal.p2.reconciler.dropins.DropinsRepositoryListener.<init>(DropinsRepositoryListener.java:82)
    at
org.eclipse.equinox.internal.p2.reconciler.dropins.Activator.watchDropins(Activator.java:532)
    at
org.eclipse.equinox.internal.p2.reconciler.dropins.Activator.start(Activator.java:172)
    at
org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
    at java.security.AccessController.doPrivileged(Native Method)   at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
    ... 12 more Root exception: java.lang.IllegalStateException: Could
not create metadata repository for:
file:/Users/apple1/Downloads/eclipse%203/configuration/org.eclipse.osgi/bundles/81/data/listener_1925729951/
    at
org.eclipse.equinox.internal.provisional.p2.directorywatcher.RepositoryListener.initializeMetadataRepository(RepositoryListener.java:112)
    at
org.eclipse.equinox.internal.provisional.p2.directorywatcher.RepositoryListener.<init>(RepositoryListener.java:59)
    at
org.eclipse.equinox.internal.p2.reconciler.dropins.DropinsRepositoryListener.<init>(DropinsRepositoryListener.java:82)
    at
org.eclipse.equinox.internal.p2.reconciler.dropins.Activator.watchDropins(Activator.java:532)
    at
org.eclipse.equinox.internal.p2.reconciler.dropins.Activator.start(Activator.java:172)
    at
org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
    at java.security.AccessController.doPrivileged(Native Method)   at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
    at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
    at
org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
    at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:389)
    at
org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1130)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
    at
org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
    at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.osgi 4 0 2011-11-23 17:04:56.923 !MESSAGE
Application error !STACK 1
org.osgi.service.application.ApplicationException: No application id
has been found.     at
org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:262)
    at
org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
    at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
    at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)  at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)     at
org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)    at
org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)   at
org.eclipse.equinox.launcher.Main.run(Main.java:1410)
share|improve this question
    
@Am1rr3zA why did you put the whole stack trace on one line? –  Matteo Nov 23 '11 at 15:49
    
@Matteo I think it was cleaner this way. –  Am1rr3zA Nov 23 '11 at 17:52
1  
@Am1rr3zA Actually Java stack traces have a format for a reason. It is stack trace and is printed as a stack (one line at a time ...) –  Matteo Nov 23 '11 at 17:54
    
@Matteo I know about java stack trace , if you insist on it I change it back. –  Am1rr3zA Nov 23 '11 at 18:38
    
* sees stack trace spans over three full screens * * pukes * –  MattiSG Nov 23 '11 at 21:05

2 Answers 2

It seems a problem with a plugin.

Try to start eclipse with the -clean option from the terminal.

share|improve this answer
    
I went to Eclipse.app/Contents/MacOS and typed ./eclipse -clean same message : / –  Zoidberg Nov 24 '11 at 6:36
    
@Zoidberg Eclipse complains about an OSGi bundle. I would try to download a fresh copy of Eclipse and run it with the same workspace. –  Matteo Nov 24 '11 at 8:52
    
i downloaded 5 including an older distribution : / –  Zoidberg Nov 24 '11 at 11:30
1  
Ok, but are you able to start with a "clean" workspace? –  Matteo Nov 24 '11 at 13:51
    
hmm, it's not getting to the 'choose workspace path' window, it crashes before that. –  Zoidberg Nov 25 '11 at 12:45

Here are a few things I would try:

  1. Check if I have permissions to write to the folder where I copied/installed eclipse.
  2. Run again with Console open, see if it generates additional information.
  3. Search for and delete the eclipse "Workspace" folder.

BTW you did not mention which version and flavor of eclipse you are running. I'm running Indigo Classic (Version: 3.7.1) on OS X Lion (10.7.2).

share|improve this answer
    
Hi Manish, and thanks for this answer! I edited its formatting to make it display a bit better. However, the second part of your answer (“you did not mention which version…”) would be better in a comment to the question. This is a Q&A site, not so much of a forum — discussion and precisions should happen in comments. Take a look at the FAQ if you need more details about how this website works :) –  MattiSG Nov 26 '11 at 14:04
    
Hey Manish and thanks for your answer. 1- check, problem still exists. 2- ran it with 'clean' flag, problem exists still. 3- it's not creating a Workspace even, it crashes before that. you have the same setup i do. I Checked the environment variables for anything abnormal, all seems to be in-place. : / –  Zoidberg Nov 27 '11 at 7:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.