Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I was facing the issue outlined on this Apple discussion thread, where I had duplicates of every contact on my iPhone -- one in iCloud, and one "Unknown". The thread presents a working solution on how to remove all "Unknown" contacts.

However, when I add a new contact without using the + button, it still goes into an "Unknown" list. Does anyone else experience this? To replicate this, try:

  1. Add a new contact, say an unknown number from your recent calls list, or from an email. 1. Save it, and go to the home screen.
  2. Go to your Contacts tab in Phone
  3. Go back to "Groups"
  4. Choose "All Contacts" Try searching for this new contact — I don't see it
  5. Go to your spotlight screen (home, then swipe left)
  6. Search for this new contact — it'll show up, and you can select it

Does anyone else see this and/or know how to solve it?

share|improve this question

closed as not a real question by bmike Mar 23 '13 at 22:02

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Is there anything else we can do to help you solve this? Did you ever resolve it? We're getting lots of "Me Too" non-answers, so I'm closing this to new answers until we can get clarification on whether you have this issue presently. –  bmike Mar 23 '13 at 22:02
    
@bmike Seems to have resolved itself in the last year, perhaps over one of the iOS upgrades. If it helps to delete the question, I'd be grateful if you could do so. –  yjsoon Jun 24 '13 at 12:20
    
No need to delete it. You can edit that tidbit into whatever answer that helped you the most or just answer it and select your answer. We just close things when they don't have an answer or prospect to get one since others tend to "answer" with "me too - how do I fix this" –  bmike Jun 24 '13 at 13:03
add comment

2 Answers 2

My guess is "unknown" is somehow the same as "On my Mac."

If you go to Address Book / preferences / accounts, do you see "on my mac" or "unknown?"

If so, if you can disable or delete it (if you're sure your contacts are all on iCloud).

That will get rid of the duplication and if/when you add a new contact on your Mac it should go up on iCloud.

share|improve this answer
    
Richard - thanks, but I mean this on iOS. Unlike Address Book preferences on the Mac, there isn't an equivalent place (that I'm aware of) to define where to put newly-created contacts on iOS. –  yjsoon Nov 26 '11 at 3:32
add comment

Go to Settings>Mail, Contacts & Calendars, scroll down and there should be a default account option near the bottom in the Contacts section.

share|improve this answer
    
The "Default Account" option is for Mail -- at least, that's the case for me on iOS 5. –  yjsoon Dec 23 '11 at 7:27
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.