Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get iCloud on my PC to sync its bookmarks with Safari, not Internet Explorer.

According to Apple's documentation, it is possible to sync iCloud bookmarks to Safari on Windows:

You can sync bookmarks between your computer and your iOS device. When syncing is enabled, all bookmarks will sync. You can sync bookmarks with the following applications:

  • Safari (Mac OS X)
  • Safari for Windows (Windows XP, Windows Vista, and Windows 7)
  • Microsoft Internet Explorer

My bookmarks are syncing fine between iPhone and iPad, so I'm sure I've got that end set up correctly.

I do have Safari 5.1.1 (7534.51.22) installed on my Windows 7 PC.

However, my iCloud control panel is only offering me the option to sync Bookmarks with Internet Explorer, and not Safari:

screenshot of iCloud control panel

Things I've tried:

Is there anything else I should try, to get iCloud on Windows to offer syncing with Safari?

(I daren't turn on syncing Bookmarks with Internet Explorer, as I have hundreds of bookmarks there, that I don't want synced to my mobile devices)

share|improve this question
up vote 7 down vote accepted

Unfortunately you have to turn it on and then it will let you change it. I'll have a look tomorrow to see if there is a preference file that can easily be changed to skip having to sync with IE.

share|improve this answer
1  
Thanks for the reply! That's impressively poor UI design. I did indeed have to turn on syncing with IE, in order to enable the Options button, which allowed me to change to Syncing with Safari instead. Beforehand, I temporarily moved all my IE favourites to a different folder, to prevent them polluting my iCloud bookmarks. All was then fine. – Clare Macrae Nov 20 '11 at 12:11
1  
Apparently the latest version doesn't support Safari - bookmarks no longer offers an options button. – marfarma Aug 21 '13 at 15:05
    
Well Safari for Windows hasn't been updated in a while, so that doesn't surprise me too much, but it does seem a little strange. – jrtc27 Aug 24 '13 at 18:30

I wanted to add. I actually performed the same action that Clare tried by moving my IE favorites before syncing. Everything worked as it did for her, but I noticed that I had to hit the "apply" button in order for the changes to take affect.

Knowing that, I chanced moving the IE favorites back unsyncing and resyincing using the Windows 7 iCloud control panel and then chose to sync with Safari instead of IE. It worked perfectly!! :)

Just thought this might help any future guests to this site. As long as you don't hit apply, it won't automatically pollute Safari and iCloud with your IE favorites which is precisely what I did not want either. At least that was my experience.

Hope this helps!!!

share|improve this answer
    
I just tried this out on a new PC, and it worked fine. Once you turn on the Bookmarks checkbox, you can then hit Options and select Safari. – Clare Macrae Mar 30 '12 at 17:17

Update :: According to the following:

http://www.howtogeek.com/132602/safari-for-windows-is-probably-dead-how-to-migrate-to-another-browser/

Safari for Windows is loosing official support, and will no longer be updated soon. From the same source (WARNING: I do NOT present this as my own opinion on the matter. This is a statement from an author at HowToGeek):

"If you’re using Safari on Windows — well, you shouldn’t be. Apple is no longer updating Safari for Windows. iCloud allows you to synchronize bookmarks between other browsers on your Windows system and Safari on your iOS device, so Safari isn’t necessary."

In addition to this, Apple support page at the following address:

https://support.apple.com/en-us/HT203519#windows

does not mention Safari for Windows as a supported browser. I do not intent to present an opinion. I am simply stating that Apple might not be supporting the browser anymore, and therefore, iCloud sync might not be worth pursuing at this point using Safari for Windows. As such, I can only suggest that you switch to either the latest version of Firefox, Google Chrome, or Internet Explorer. I am a bit late to this, so I apologize if I have complicated anything.

Just providing an updated answer, with new documentation.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.