Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying to delete a file, but I get a message from Trash saying:
"The operation can’t be completed because backup items can’t be modified."

The operation can’t be completed because backup items can’t be modified.

What does that mean and how can I delete it?

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

According to this thread at Apple, this is a bug. This means it will hopefully be fixed in a coming update to OS X.

In the meantime, you have to relaunch the Finder, which you can do either through force quit (⎇⌘⎋, or through the  menu), or by less violent means by quitting it normally, which you must first activate through the following command issued in the Terminal:

defaults write com.apple.Finder QuitMenuItem 1
share|improve this answer
    
Thanks, as suggested in the thread rebooting worked. –  Louis Nov 20 '11 at 17:03
1  
You could always do killall Finder in the Terminal –  segiddins Apr 3 '13 at 2:42
    
Option-click on the Finder's Dock icon and choose Relaunch Finder. –  Kirk McElhearn Apr 3 '13 at 7:20
add comment

The root of the cause

Time Machine backups are protected at kernel level -- on a verbose boot it's possible to spot in the first screenful of text a TMSafetyNet.kext extension being loaded.

This ensures the integrity of your backups. Access control provisions are applied via a kernel extension located at /System/Library/Extensions/TMSafetyNet.kext

Deleting in Time Machine

The officially sanctioned method for deleting items from a specific backup or all of them is to locate the item in the "in space" Time Machine view and selecting the appropriate delete option from the contextual menu or the Action button in the toolbar.

The ability to move backups to the Trash added in Lion is not only comparatively more buggy, but designed to operate on entire snapshots, i.e. the folders named with the time the backup was created which in turn contain a directory for each included volume.

Deleting from commandline (more flexible, more control)

There exists a a helper program (commandline binary) at...

/System/Library/Extensions/TMSafetyNet.kext/Contents/MacOS/bypass

...which allows you to supply a command and argument to completely bypass the access restrictions.

In Lion you run:

sudo /System/Library/Extensions/TMSafetyNet.kext/Contents/MacOS/bypass rm -rfv /Volumes/[disk]/Backups.backupdb/[path]

In Mountain Lion bypass moved to the Helpers directory:

sudo /System/Library/Extensions/TMSafetyNet.kext/Helpers/bypass rm -rfv /Volumes/[disk]/Backups.backupdb/[path]

Credits:

[1] - Michael Rushanan on TMSafetyNet bypass
[2] - A brief explanation of the Time Machine Safety Net by Joel Cowgill
[3] - Similar question on SuperUser

share|improve this answer
1  
Yay, this worked indeed! Entering Time Machine and deleting the file from there was not an option since this backup is linked to another user. However, after deleting the *.exe files using your solution, the Finder would still show them as present. I had to kill the Finder process for the displayed content to refresh. –  gentmatt Apr 1 '13 at 19:35
    
This is now moved to: "/System/Library/Extensions/TMSafetyNet.kext/Helpers/bypass", and otherwise works as advertised. –  David Pisoni 2 days ago
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.