Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On my Snow Leopard Mac, I can't seem to paste into a password field on login pages to Apple sites, (developer.apple.com for example). I thought is was a browser issue but it's happening with Safari, Chrome and Firefox so it must be the System. I assume this is somebody's idea of a security feature, though I fail to see the logic and it's very annoying.

Any ideas on how to fix, turn off or work-around this?

share|improve this question
3  
It's not the system, its the field. Apple added JavaScript which disables pasting into it. (jackJoe's answer probably indicates a bug in Firefox, since that shouldn't work.) –  ughoavgfhw Nov 18 '11 at 15:23
    
Ah, that makes more sense. I always forget about that pesky js. –  TheGeoff Nov 18 '11 at 16:59
    
@ughoavgfhw actually it used to work, probably on a different version of Firefox or a different javascript than before, because I just tried it with FF 4 and no luck... It does work in other cases, I suppose Apple's javascript in these pages is more clever now. –  jackJoe Nov 18 '11 at 19:01

5 Answers 5

Right-click on the password field and under the menu that appears, select "paste" (it happens to me in Firefox and that is my fix).

share|improve this answer

Use the web inspector in webkit based browsers and remove the onpaste="return false;" attribute and you'll be able to paste your password.

share|improve this answer

This is exactly why I have a keyboard for Safari to disable JavaScript and that feature is one reason why I prefer Safari.

It is also handy on sites which try to block the 'copy' command or otherwise abuse JavaScript.

I can enable/disable JavaScript just by pressing ⌘ + J

The GUI way

  • Launch Safari
  • Go to Preferences
  • Go to 'Advanced' preferences
  • Click 'Show develop menu in menu bar.
  • launch System Preferences
  • go to Keyboard preferences
  • select 'Keyboard Shortcuts'
  • choose 'Application Shortcuts'
  • click the + button
  • set Application to 'Safari'
  • set the Menu Title to 'Disable JavaScript' (note that Capitalization is important, it must be exactly the way it is shown in Safari)
  • set the keyboard shortcut to something like ⌘ + J

The Command Line Way

If 12 steps seems like a lot of hassle, try these two (Note: Safari must not be running when you make these change)

defaults write com.apple.safari IncludeDevelopMenu 1

(That is the equivalent of the first 4 GUI actions.)

defaults write com.apple.safari NSUserKeyEquivalents -dict-add "Disable JavaScript" '@J'

(This is the equivalent of the last 8 GUI actions.)

Note that the '@J' on the command line is equivalent to ⌘ + J. See http://www.mactipper.com/2008/02/add-keyboard-shortcuts-from-command.html for more information on adding keyboard shortcuts via Terminal.app.

share|improve this answer

Like TJ's answer, there's also an extension for Firefox that lets you toggle javascript on and off to disable paste and copy blocking, among others - YesScript

No advanced configuration, just install it and click the white page icon on your bottom addon bar when you need it (Ctrl + / to toggle the bar)

And a Chrome equivalent: Quick Javascript Switcher

share|improve this answer

I came to this thread as the result of Expedia blocking password pasting. I eventually determined that disabling JavaScript (JS) allowed me to paste into the password field.

There are now simple apps for your browser that allow you to quickly and easily toggle JS.

  • Chrome has an app called 'Quick Javascript Switcher'.
  • Firefox has QuickJava.
  • I found this for Safari but I haven't tested it
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.