Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently turned Match on in iTunes, and it did its thing and matched/uploaded songs. I then turned it on in my iPhone and to my horror, the tags that I thought I had meticulously organized weren't quite so perfect... mostly due to the "album artist" tag.

For example, the artist list in my iPhone now displays "Smashing Pumpkins" and "The Smashing Pumpkins". I went back to iTunes, corrected all the issues I could find, and hit "Update iTunes Match", thinking this would send in my corrected tags. Once it finished, I checked my phone to find that nothing had changed. I then checked back in iTunes to find that it had actually uncorrected the tags I just fixed, and they're now back to the way they were when I sent them into Match.

Is there a way to get Match to recognize changes to id3 tags, or am I forever stuck with what I've got?

share|improve this question
add comment

2 Answers

up vote 5 down vote accepted

I had a similar issue, it seems as once the song is uploaded to iCloud via iTunes match it becomes the "Master" copy. Install iTunes 10.5.1 or later on another PC and connect it to iTunes Match but DO NOT download anything! Then you can delete songs from iCloud, don't worry this won't delete them from your main iTunes library. Once deleted go back to your main iTunes machine and change the metadata, then choose add to iCloud for the song. The new metadata will now be ULd to iCloud.

share|improve this answer
    
This worked perfectly -- thanks! –  Mike Nov 18 '11 at 7:05
1  
if you dont have another PC you can just copy the file to your desktop (or any folder outside of your itunes library) and then delete the song from iTunes and check the box for 'also delete from iCloud'. This will completely remove it from iCloud. Then modify the mp3 info and re-add to itunes (via drag n drop, or 'file -> add file' –  Baldy Dec 19 '11 at 9:20
add comment

I've had success with a slighly different approach which (as a plus) doesn't require re-adding all your tracks.

First, I turned off iTunes Match on my iMac (desktop) where my library resides. Then, I cleaned up all my metadata.

Next, I went to my Macbook Air (laptop), opened iTunes, went into iTunes Match, and deleted everything. As earlier posts have pointed out, despite the warnings iTunes gives you, this does not have the effect of deleting anything out of your local iTunes library (on my iMac, in my case).

Go back into iTunes on my desktop, and turn on iTunes Match. This starts the standard 3 step process, which finishes pretty quickly (in my case - my library is ~8k songs).

When it's done, all my tracks have been re-associated w/ iTunes Match, and have taken the new metadata assigned to them. Confirmed by going back to my laptop, quitting out of iTunes and re-launching, and waiting for iTunes Match to sync. After sync, my library appears, and contains the updated metadata.

Would be interested to know if this works for anybody else!

share|improve this answer
    
what do you mean by 'went into iTunes match'? –  Baldy Dec 19 '11 at 9:21
    
@Baldy I believe he meant he deleted all the songs from the library (which are in iTunes Match). There's no "iTunes match" per se. –  Martín Marconcini Dec 21 '11 at 13:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.