Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I click "Turn On Photo Stream" on in iPhoto it reports "iPhoto unable to connect to Photo Stream." It shows the correct user name on the Photo Stream screen in iPhoto. I have the correct credentials provided on the iCloud App in System Preferences, and Photo Stream is turned on there.

Running Mac OS X 10.7.2, iPhoto 9.2.1 and iOS 5.0.1. System Updates, App Store and iPhoto reports everything is up to date and running the current version.

I am connected to the Internet and able to visit iCloud.com and log into my account just fine. iTunes, and other apps all seem to work fine.

share|improve this question
    
I have the same problem and spent 2 hours with three levels of apple technicians on Sunday. They are going to trouble shoot it and get back to me Friday. It seems to be a problem many are having. –  user13708 Nov 15 '11 at 18:56
    
@user13708 Sounds like it might be a server issue. Please let me know what you find out. –  Jim McKeeth Nov 15 '11 at 20:47
    
I had the same problem. It looked like it was Little Snitch. Even though I had allowed photostream access in Little Snitch, I found when I deleted the old rule for photostream I got a new request which I allowed again. Then everything started to work as expected. –  markhunte Feb 5 '12 at 3:27
    
I have the same problem .... It appears Mountain Lion is the culprit .... everything has gone wrong since he arrived.. I have no answer .... I HAVE THE PROBLEM .... iPhoto and PhotoStream cannon connect ..... FURIUOS ! –  user28253 Aug 29 '12 at 18:36

2 Answers 2

System Preferences -> iCloud, Check Photo Stream.

share|improve this answer
up vote 0 down vote accepted

The answer I went with was to contact Apple's support. After spending about 4 hours on the phone over 3 different occasions the problem still isn't solved. They are going to get back to me again hopefully.

share|improve this answer
    
They never got back to me, but it started working after this latest iCooud update. –  Jim McKeeth Mar 22 '12 at 18:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.