Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On my Macbook Pro, whenever you press the power button it goes into sleep mode. How do I change this to do nothing?

share|improve this question

2 Answers 2

up vote 6 down vote accepted

You can control whether pressing the power button should put your mac to sleep or present a dialog with options (sleep/restart/shut-down) using the pmset command. The following:

sudo pmset powerbutton 1

will put it to sleep right away (presumably your current setting) and changing 1 to 0 will present you with the dialog.

Pay attention to the fact that it's not a per-user setting, and changes the behaviour for all users. Something to keep in mind if you share the device with others. From the man page (explore it for other options):

All changes made through pmset are saved in a persistent preferences file (per-system, not per-user) at /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist

share|improve this answer
2  
Seems this does not work for Mavericks. It gives "Usage: pmset <options>" output. Any thoughts? –  lulalala Oct 28 '13 at 6:33
2  
I can confirm, pmset in Mavericks doesn't accept powerbutton arguments. –  nine9ths Nov 12 '13 at 21:07
1  
So irritating that someone clear used time to remove functionality that everybody is crying for now! –  mabartibin Dec 12 '13 at 14:42

i was searching that too , here it is : http://www.tips-and-tricks-in-mavericks.com/use-your-macbooks-power-button-to-turn-off-its-display-in-mavericks/

share|improve this answer
    
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  George Garside Oct 28 '13 at 21:09
    
The link just suggests using Ctrl-Power (or holding power for 3 seconds) in order to bring up the old menu. It doesn't give any suggestions for disabling the new instant-sleep behavior entirely. –  Quantum7 Feb 4 at 9:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.