Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Since upgrading to Max OS X 10.7.2 and converting my MobileMe Account to iCloud I am receiving endless dialog boxes asking about syncing Yahoo Contacts.

I cannot find settings anywhere to turn this off. I have to manually dismiss these frakking dialogues, which come up at the rate of about one an hour.

share|improve this question

3 Answers 3

I was curious about this myself and started by looking in Activity Monitor, found that "launchd" was the service that kicked off the Yahoo Contacts Sync. After some googl'ing I found out that custom scripts for launchd get executed from the ~(user)/Library/LaunchAgents folder. In there, you'll find the culprit -- at least, I did. Now I dunno if I should simply delete them (since I don't care about syncing contacts, I don't use the Mail.app) or if I can just disable it by tweaking the plist file. Hope that helps!

EDIT: I discovered that going into the AddressBook.app preferences and unchecking the accounts listed caused the plist files to be removed. If you check them again, they reappear. Works for me! :)

share|improve this answer
up vote 1 down vote accepted

Here is how I solved this:

  1. launch Address Book
  2. go to Preferences -> Accounts tab -> On My Mac item
  3. check Synchronize with Yahoo! box (which was unchecked for me)
  4. choose cancel in the resulting dialogue box

I can only guess that checking Synchronize with Yahoo! and canceling the resulting dialogue shook some sense into some forgotten settings.

share|improve this answer

Both Address Book and iTunes have (or had) UI for authenticating with Yahoo and enabling contact sync. When you migrated to iCloud, the UI probably went away.

One heavy-handed technique to solve this would be to remove /System/Library/PrivateFrameworks/YahooSync.framework from your system.

share|improve this answer
2  
I think I must have overlooked the Yahoo! (yes, I am compelled to write it that way) syncing option in Address Book because its box was unchecked. But going through the preferences in Address Book and toggling the sync option from off (but not really off) -> on -> off was how I solved this. –  roosto Dec 16 '11 at 22:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.