Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the keyboard set to "British" and my locale is Australia, but neither of these seem to affect the spelling suggestions.

share|improve this question
up vote 2 down vote accepted

Spelling is determined by the keyboard setting you're using. Go to Settings > General > International > Keyboards, and make sure that English (UK) is added. It also helps to remove the US keyboard so that you don't accidentally get stuck in that.

share|improve this answer
THANK you! Now I realise it was the "hardware" keyboard I had set to British, and it was an English (UK) software keyboard I had to add. – Robert Atkins Nov 13 '11 at 11:36
Glad to help. It seems obvious when you know, but it isn't the most intuitive thing. – nthonygreen Nov 14 '11 at 12:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.