Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have Logitech K750 (solar thingy) attached to Lion. For some weird reason § and < keys have traded places. I have checked keyboard settings and everything is correct. I downloaded KeyRemap4MacBook but I can't find how to actually change mappings with that program.

Can anybody tell me how to get my < in the right place, it's really starting to annoy me when doing HTML and CSS...

share|improve this question
add comment

2 Answers 2

It sounds like a keyboard type glitch, the machine thinks it is ANSI instead of ISO or vice versa. See if this helps:

Sometimes a machine will forget which type keyboard is attached, with the result that certain keys get transposed from what the user expects. The fix for this is run the Keyboard Setup Assistant again. Sometimes there is a button for "Change Keyboard Type" visible in System Preferences/Keyboard. If not, you can try trashing the file

sudo mv /Library/Preferences/com.apple.keyboardtype.plist /Library/Preferences/com.apple.keyboardtype.plist.orig

Another possibility may be to open Terminal and type:

sudo open /System/Library/CoreServices/KeyboardSetupAssistant.app/Contents/MacOS/KeyboardSetupAssistant
share|improve this answer
    
Yeah, there's a common in the blog post from a guy who has exactly same problem. I tried KeyboardAssistant but it can't recognize the keyboard :/ –  StevenJ Nov 10 '11 at 17:48
    
Hi! I using Mountain Lion, but I do not have Change Keyboard Type nor /Library/Preferences/com.apple.keyboardtype.plist file in my laptop. However, KeyboardSetupAssistant exits with "No unknown keyboard connected - terminating"... is there any other way to reset this setting? –  Gabor Garami Sep 29 '12 at 14:44
add comment

Have you done the keyboard recognition in System Preferences, Keyboard, Change Keyboard Type? To what type of keyboard have you set it? US?

share|improve this answer
    
I don't have "Change Keyboard Type" in my Keyboard preferences. –  StevenJ Nov 10 '11 at 17:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.