Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently tried to do a screen repair on an iPhone 4.

It won't boot fully, so I may have managed to break something else. Basically it wont turn on, and I only get a flashing Apple logo when plugged into a computer. I believe it could be the motherboard, although I have visually inspected it extensively to determine if i could have physically broken anything. I could not detect any fault. When I use the suspect motherboard on another iPhone frame I get the same problem.

share|improve this question
If you have a mac - you might try getting Xcode and see if you can look at the console log and determine where in the boot process it is failing. Also - if you can't restore the device that would point to a lower level hardware failure. There are lots of guesses what could be the error (just start listing the components for a computer. RAM, storage, CPU, controller, etc...) but you don't need a screen to boot the device and see that it's running in Xcode. – bmike Nov 7 '11 at 15:49
ok, dowloaded Xcode (3 for snow lepard). However I am not sure how to use the console log, to determine the codition of my probelm? any help @bmike – dgamma3 Nov 8 '11 at 11:37
Just the fact that you can see some messages indicates that the iOS is loaded correctly and the hardware is mostly working. Conversely, if there is nothing to see, then the chances are that the logic board needs to be replaced / repaired. What are the last 4 messages (or 10) you can see while the device is connected and booting? – bmike Nov 8 '11 at 19:24
Please accept the answer that solved your problem. If you did something else that is not in the answers yet, post and accept your own answer. – vrwim Apr 2 '15 at 16:05
@bmike, how does one use Xcode to view a console log on a device that is failing to boot? It seems that it would never actually become accessible to connect in Xcode. – Syclone0044 Apr 23 at 5:49

Get into DFU mode and do a restore in iTunes.

For DFU mode:

  • Turn the iPhone off (not needed in this case :)
  • Push the sleep button for 3 seconds (Apple logo should appear)
  • Push both buttons for 10 seconds (Apple logo should disappear)
  • Release the sleep/wake button and hold the home button for at least 15 seconds.

Nothing will show up on the screen, but if you connect it to iTunes it should recognise it. Then do a full restore.

If that doesn't work, you screwed something up inside, you might want to open it up again and re-check all connections.

share|improve this answer

I had the same issue when a car ran over my partner's 3GS: I changed the broken screen and front glass and all it did was flash on and off with the Apple logo and get hot.

My solution was to re-check all connections, start iTunes on my laptop, plug in the phone, hold the power and home button for 15 seconds, and (eventually) it'll go into recovery mode (this took me about 6 tries).

share|improve this answer

try to change the battery. it worked for me

share|improve this answer

More than likely you ripped the battery terminals off the motherboard. When connected to the computer it tries to boot but fails to detect a battery. Look very carefully at where the plug attaches to the board. You'll see one or several little brown patches where terminals for the plug to plug into were once attached. Look at the battery plug.....that's where they now are.

share|improve this answer

I attempted a battery replacement on my daughter's iPhone 4. After a bettery remove and replace (not the R&R we all hope for!) her phone did similar things as yours.

Check the connector on the main board your battery plugs into. Be really careful when you do this and don't remove the battery again if you don't need to. During the R&R, I managed to break the surface-mount solder joints and remove the main board side of the connector with the battery lead. I don't know if the connection was a pre-existing condition, or if my removal technique was sloppy or overly forceful.

I rectified the condition by upgrading my 4s to a 5 and giving her my "old" phone. If you're eligable, now might be a good time to consider a carrier-subsidized upgrade. If you're not, look for a friend with a 4s who is eligible for an upgrade but hasn't exercised it yet. See if you can pay for their upgrade fee, getting them a new phone and you a $200 replacement.

Good luck!

share|improve this answer

I had the same problem when I did a screen repair if you replace the screw in the EXACT place you removed them from the phone will no work properly ie no wifi, not charging, no call ect I hope this helps you with your problem :)

share|improve this answer
That really makes no sense at all to me... – Tetsujin Nov 30 '14 at 14:12

Have you tried DFU mode and restore via iTunes? DFU mode is turn off > home + sleep 10 seconds > release the sleep button, until a "connect to iTunes" appears.

share|improve this answer
Are you confusing recovery mode and DFU mode. Nothing should show on the device screen in device firmware update mode.… – bmike Nov 7 '11 at 17:32

My iphone 4 is doing the same thing. My diagnosis came down to this... just like my iPhone 4, your iPhone is broken and need a hardware repair.

I tried this DFU crap 4 times and got unknown error occurred (21) each time.

From my experience, I'm pretty sure unknown error (21) is apple code for completely "effed".

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.