Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In Pages, you can change the default language to British English in the Inspector --> Text --> "More" tab --> Language: British English.

However, this reverts somehow in every launch of Pages. How do I set British English as the default language so that vocabulary checks are done according to British English?

share|improve this question

5 Answers 5

up vote 2 down vote accepted

To follow up Martin's answer, for British English you will need to edit the list and check the "British English" tick box. I spent while looking for "English (British)", but it's the former format that appears.

share|improve this answer
    
Oh yeah, I didn’t mention that because turns out that my list is heavily customized (as you can see) I removed all the things I can understand, but on a default installation, the list will be much larger. ;) –  Martín Marconcini Oct 14 '10 at 12:14

You have to change the settings in the "International" panel in System Preferences.

  • Go to System Preferences.
  • Go to the Language & Text (In 10.6) panel (the language tab appears first by default).
  • Put your preferred language at the top of the list (you might have to edit the list).

Relaunch your iWork application (Pages, Numbers, Keynote) and your preferred language will be used as default language.

Language & Text

share|improve this answer

I believe the only way to do this is to change the spelling language in a blank document and save it as a template.

Under General Preferences, you can select "Use Template:" and choose that template you saved.

share|improve this answer
1  
Incorrect there are many other ways to do this. –  user588 Oct 11 '10 at 20:00

I suggest that you try Language Switcher.
It’s a freeware software, that launches single applications with a different language.

I tested it with many software but I don't know if it works for pages too, please try it and tell us if it works or not in the comments.

alt text

share|improve this answer

If you don't mind changing the UI in addition to the spell checker, the following commands:

cd ~/Library/Preferences/
defaults write com.apple.iWork.Pages.plist AppleLanguages "(Dutch,English)"

Would make the Pages UI (menu items, spellcheck, etc.) use Dutch first, and then English anywhere where the Dutch translation or dictionary is not provided. I leave it as an exercise to the reader to find out if it is "British" or "British English" or "GB-EN" or etc. to set it to British English UI and spell checking. Please leave the answer as a reply / comment to this answer.

Some more details here and here.

share|improve this answer
    
It’s British English (for the lazy) –  Martín Marconcini Oct 14 '10 at 12:14
    
(or busy) [filler for character limit]. –  user588 Oct 14 '10 at 18:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.