Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying to turn off the Web Sharing service from the Preferences panel, but everything I try, it just gets stuck on ‘Interrupting...’, with an orange icon, and it doesn't do anything. If I close the Preferences panel and come back, I find it turned on again.

(I reckon that it's not stopping due to the missing /System/Library/LaunchDaemons/org.apache.httpd.plist, because when I try to stop it using the terminal, with sudo apachectl stop, I get an error that says that it can't find that file)

What could I do to fix it?

share|improve this question

4 Answers 4

Perhaps try sudo killall httpd? I'd also check Console to see if there's any errors.

share|improve this answer
    
It kills just my own Apache server (installed separately) but not the built-in one! :( –  entropid Nov 4 '11 at 23:48

If you're missing launch daemons from your /System/ folder, the best long-term solution is to perform an Archive and Install so that you keep your content and simply rebuild your damaged operating system.

share|improve this answer

Did you delete /System/Library/LaunchDaemons/org.apache.httpd.plist? If so, either replace it with a copy from another Mac (so it can be disabled properly), or reboot the computer (since it doesn't exist, it won't get loaded on reboot).

share|improve this answer
up vote 0 down vote accepted

The only way to fix it was to reinstall OS X.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.