Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a network with 2 Mac OS X computers in it.

When I try to print a text document from my upgraded OS X 10.7 to the shared printer on OS X 10.6, my print job gets stuck at the "job pending on server" message.

When I look at the printer spooler on the 10.6 machine, I see the job as "printing" and the message "sending data", but the printer doesn't print anything. There's no reaction at all, and yes – I checked the cables.

enter image description here

share|improve this question
up vote 2 down vote accepted

Solved the Problem. The shared Printer was connected to a Belkin USB Hub, which again was connected through an USB slot to the Mac OS 10.6 Laptop. I disconnected the printer from the Hub and plugged it straight into the usb slot of the laptop, when I tried again print out a document, it succeeded

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.