Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Every once in a while my screen dims, I don't want that to happen. Just now it did it while I was moving the mouse.

share|improve this question
add comment

4 Answers 4

up vote 7 down vote accepted

Under displays in system preferences there is a checkbox (along with a brightness slider) to enable/disable automatic brightness.

share|improve this answer
add comment

I'd suggest you install a brilliant app called Caffeine. It's free and will do exactly what you're after. It sits nicely in your menu bar and with a simple click toggle you can enable activate/deactivate it. It also allows it to be activate for a set amount of time.

If you don't want to use a 3rd party app you can always disable Display sleep via Energy Saver preference pane.

share|improve this answer
    
I mean while I'm using the computer actively. Ceffeine seem to be a solution to it getting dimmed when you are watching movies and things, but I was using my keyboard and things. –  Kit Sunde Nov 1 '11 at 6:37
    
I'd still suggest going with Caffeine. I believe MacBooks tend to adjust the brightness based on the ambient light even during active work. Using Caffeine does the job for me in that area, too. –  Michal M Nov 1 '11 at 6:50
    
Oh I didn't know I had ambient light dimming. –  Kit Sunde Nov 1 '11 at 7:00
add comment

Go to System Preferences » Energy Saver

If you never want your display to dim and then turn off, set Display Sleep for Never. You can also deselect Automatically reduce brightness before display goes to sleep if you want.

enter image description here

share|improve this answer
    
I have those settings already and it still dims. I've also unchecked the "Automatically reduce brightness before display goes to sleep". –  Kit Sunde Nov 1 '11 at 6:36
    
In that event, ambient light changes are likely your problem, and the answer you accepted is dead on. –  Daniel Lawson Nov 1 '11 at 16:01
add comment

It's true that the Ambient Light Sensor causes this problem in many cases. But I want to present an alternative answer.

If your power adapter is plugged into a wall socket or a power strip and the connection is loose, the computer will switch between Battery mode and Power Adapter mode. Since many of us have different power settings for Battery vs. Power Adapter mode, this will cause the screen to randomly dim and undim.

The fix is simple.

Snapshot of MacBook Energy Saver preferences window

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.