Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I opened up Dropbox and received this error:

Dropbox Error

I am on an Intel i5 MBP running 10.6.8. Dropbox is version 1.1.45.

Console log:

11/1/11 9:54:56 AM  [0x0-0x156156].com.getdropbox.dropbox[2434] 'import site' failed; use -v for traceback
11/1/11 9:54:56 AM  [0x0-0x156156].com.getdropbox.dropbox[2434] Traceback (most recent call last):
11/1/11 9:54:56 AM  [0x0-0x156156].com.getdropbox.dropbox[2434]   File "Resources/__boot__.py", line 103, in <module>
11/1/11 9:54:56 AM  [0x0-0x156156].com.getdropbox.dropbox[2434]   File "Resources/__boot__.py", line 101, in _argv_emulation
11/1/11 9:54:56 AM  [0x0-0x156156].com.getdropbox.dropbox[2434]   File "Resources/__boot__.py", line 7, in _get_argvemulator
11/1/11 9:54:56 AM  [0x0-0x156156].com.getdropbox.dropbox[2434] zipimport.ZipImportError: can't decompress data; zlib not available
11/1/11 9:54:56 AM  Dropbox[2434]   Dropbox Error
11/1/11 9:54:56 AM  Dropbox[2434]   Dropbox Error An unexpected error has occurred during execution of the main script
ZipImportError: can't decompress data; zlib not available
11/1/11 9:54:58 AM  com.apple.launchd.peruser.504[607]  ([0x0-0x156156].com.getdropbox.dropbox[2434]) Exited with exit code: 255
share|improve this question
2  
Did you "Open Console"? –  patrix Nov 1 '11 at 5:26
1  
I concur with @patrix: the Console output would be more than helpful to diagnose this. –  kopischke Nov 1 '11 at 7:55
    
Also, have you tried manually updating to the latest stable build? –  Bradley Chambers Nov 1 '11 at 11:01
    
Have you exhausted the dropbox support website? They will know the best how to react to errors in their program. List a little more in your question - what you tried / what versions of DropBox and your OS for sure. Perhaps if you are on Intel/PPC might be relevant. –  bmike Nov 1 '11 at 14:32
    
@patrix Thanks for adding the log file. I couldn't figure out how to format it right. –  daviesgeek Nov 1 '11 at 18:33

1 Answer 1

up vote 2 down vote accepted

Google showed that it is the case with 10.3 while Dropbox only support 10.4 and upwards.

Judging by the screenshot it is not your case so there is either a problem with zlib on your system or with permissions. Then either Disk Utility or booting from install disk and repair user permissions might help.

If nothing above try to remove Dropbox with a cleaner app and install anew.

share|improve this answer
    
I re-installed Dropbox. Don't know what happened, but thanks for your quick answer! –  daviesgeek Nov 2 '11 at 22:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.