Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a MacBook Pro with 10.6 pre-installed. Is there a way to use this machine to test my software on 10.5?

  • Do I need 10.5, or is there is a mode within 10.6 with which I can run 10.5?
  • If I need 10.5, how can I get it?
    • Do I need to buy the 10.5 OS? (if so, where does one do that?)
    • Does 10.6 somehow include 10.5 with it?
    • Do I already have a license for 10.5 by buying 10.6?
  • How do I install 10.5 once I have it?
    • Will it work in Virtualbox?
    • Do I need to dual boot?
share|improve this question
    
side-question: are you sure you want to bother? In case you do, since you need that for testing reasons, why would you want to test something on a very nonstandard system such as the one you are trying to build? That wouldn't be a good test anyway. –  Lohoris Aug 3 '11 at 15:30
add comment

2 Answers 2

up vote 6 down vote accepted

No, this will not work. You can have multiple versions of OS X on one machine, but you can only install newer versions than the one that came pre-installed. For example, if your machine came with 10.6.4, you can't run 10.6.3 or older.

When Apple releases new hardware, the drivers for that hardware get rolled into a special build of OS X that comes only on that model. They don't get added to OS X in general until the next point release. (That means that drivers for the hypothetical machine I'm talking about wouldn't be added until 10.6.5.)

Apple doesn't release drivers as standalone software, which effectively makes it impossible to install and older version of OS X than what your Mac shipped with. You'll find that if you put the install disc for an older version in the drive, it either won't boot or it will refuse to install.

However, you can go the other direction. If you have an old Mac running 10.5, you can use Disk Utility to make another partition (HFS+ Journaled), then boot the install DVD for 10.6 and install it to that partition. To switch between the two after installing, hold alt when you boot up. (You can also select the default boot partition through the Startup Drive pane in System Preferences within either OS X install.) Boot camp is not required for this. Boot camp is only required for installing non-Apple operating systems like Windows and Linux.

share|improve this answer
    
Good answer. What about virtualbox or vmware? –  Paul Biggar Oct 7 '10 at 13:42
    
VirtualBox does have an EFI emulation mode now, but I'm not sure how well it works. Apple's license agreement forbids using OS X client within a virtual machine. (OS X server, on the other hand, can be virtualized, as long as it's on an OS X server host with a separate license key.) –  Ben Wyatt Oct 7 '10 at 14:34
1  
hmm, irritating. OK, thanks! –  Paul Biggar Oct 7 '10 at 14:40
2  
@Paul: following link may be helpful, and there is obviously a lot more info out there via google about running OS X in virtualbox: lifehacker.com/5583650/run-mac-os-x-in-virtualbox-on-windows –  Robert S Ciaccio Oct 7 '10 at 15:00
    
@Paul hackint0sh's will run in a vm but don't always work how you'd want them too. –  ing0 Nov 24 '10 at 14:31
add comment

I would think partitioning the disk and using Boot Camp is all you need to do here.

If you don't have a 10.5 disk already, then you'll need to go through Ebay and sites of its ilk. Apple doesn't sell previous versions of OSes.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.