Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I own a MacBook Pro, 17", MA897D/A, A1229, Mid 2007, with a display resolution of 1920x1200 which worked seamlessly under 10.4.

As I upgraded to Lion I sadly noticed that the maximum resolution now is 1680x1050.

Did anybody experience similar behaviour? Is Lion unable to detect the native resolution? Are there any 'power settings' I could use?

share|improve this question
    
I am assuming you have the optional 17" Wide SCreen TFT. The standard spec for the 2007 17" only supports 1680x1050, however, the optional TFT does support 1920x1200. Specs here and here –  Diago Oct 25 '11 at 12:00
    
Have you booted in safe mode and gone to the System Information app - chosen Window - About this Mac and made sure the OS itself is reading the Display correctly. You do get 90 days of phone/online service support and you might get the fastest answer by calling on Apple to get to the bottom of this if the drivers didn't install / operate correctly. –  bmike Oct 25 '11 at 14:32
    
That is correct. Your monitor's native resolution is 1680x1050 (as Diago has pointed out). Lion is operating normally. –  cksum Oct 27 '11 at 22:16
    
No, Diago and cksum. As I pointed out the native resolution of 1900x1200 works on Mac OS X 10.4 Tiger. –  MacUser Nov 5 '11 at 21:34
add comment

2 Answers

The current 17" MacBook Pro which ships with Lion also has a native resolution of 1920 x 1200:

http://www.apple.com/macbookpro/specs-17inch.html

My guess is Making a new user or booting into safe mode will help you sort out whether something got munged in your user account in the Lion install.

share|improve this answer
    
His MBP is not the current model, it is one from 2007 which did offer a high-res screen. –  cksum Oct 27 '11 at 22:15
add comment

This is what I would try:

Open /Library/Preferences/com.apple.windowserver.plist with a PLIST editor. Look under DisplaySets > Item 1 > Item 1 for the "Width" and "Height" values. Change them to 1920 and 1200 respectively. Save, restart, see if it fixes it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.