Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently bought a new macbook pro with Lion, had some problems and had it checked by Apple people. It was returned to me but the software update server seems to have been changed and will not update. How can I change to the official one? I would like to avoid the 2 hour drive. Thanks!!

share|improve this question

migrated from Oct 25 '11 at 3:06

This question came from our site for system and network administrators.

It depends on exactly how they changed the update server setting. If they did the obvious thing, this should delete the setting (so it'll go back to normal):

sudo defaults delete /Library/Preferences/ CatalogURL

If that doesn't work, it's possible it's configured as a per-user (rather than system-wide) setting, in which case this should do it:

defaults delete CatalogURL
share|improve this answer

On system newer than 10.10

sudo softwareupdate --clear-catalog
share|improve this answer

Before driving to the Apple technician, you can type the following Terminal command:

defaults read /Library/Preferences/ CatalogURL

This will tell the the URL that SoftwareUpdate is checking.

share|improve this answer
Would you be willing to expand slightly on this? We are looking for good, in-depth answers. Perhaps you could include the steps needed to get to this point? – bassplayer7 Feb 22 '13 at 1:53
On OS X 10.8.2, when testing the above answer, I get this error: The domain/default pair of (/Library/Preferences/, CatalogURL) does not exist – gosmond Feb 22 '13 at 4:39
@gosmond: that means that your computer will use the default -- Apple's servers. – Gordon Davisson Feb 22 '13 at 5:34
@GordonDavisson, OK, then machead should make that clear in the answer, so that people who try the command aren't left scratching their heads by an apparent "error" in the output. – gosmond Feb 22 '13 at 6:59
sudo defaults rm /Library/Preferences/

then reboot

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.