Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Currently, Terminal is set to handle SSH urls. For example, if I do:

$ open ssh://

Then it will spawn a new SSH session in terminal. I'd like these to be opened in iTerm2 instead. How do I tell OSX to use iTerm2 to handle ssh:// URLs instead of Terminal?

share|improve this question
up vote 35 down vote accepted

iTerm2 can set itself as the default SSH handler. In its preferences, go to “Profiles”. Create a profile to handle SSH sessions, or select an existing one. In the “General” section, bottom right, you can select which URL scheme this profile should handle:

Screenshot of iTerm2 preferences, General section of Profiles pane

Select SSH. iTerm2 will ask if it is to set itself up as the default SSH handler:

Screenshot of iTerm2 asking for confirmation to set itself up as the default SSH handler

Confirm and you are done. Happy remoting.

share|improve this answer
OK, now I have to figure out how to get iTerm to open a new window instead of a new tab, but that's a separate question... – Lorin Hochstein Oct 23 '11 at 22:07
The interface is still the same but the changes dont ever seem to take effect for me. Should this still be the correct answer or is a bug in the current version (v2.1.4)? – Jeff Oct 20 '15 at 20:43
Similar to @Jeff I experience the change to only take effect for a very short time (if at all). Then Terminal takes over again. – stefanfoulis Feb 19 at 13:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.