Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I initially got my MacBook, I connected my external monitor and it worked fine. Last night I disconnected it and when I connected them back together, the resolution on the external monitor was changed. The overall display is now magnified (for example as I'm writing this I have to scroll down to see this).

I tried to change the resolution settings in Preferences but this didn't help to change it back. So how can I set the resolution of the external monitor back to a sane state?

share|improve this question
    
Unplugging the monitor and plugging it back in fixed a similar issue I was having with Lion. –  Nathan Greenstein Jan 22 '12 at 4:49
    
I have the exact same problem! I now set my external monitor resolution to 1440x900 (as always did) but it's definitely at a lower resolution. I tried turning it on and off, selecting diferent resolutions, plug-unplug, etc to no avail. Any ideas? –  Ignacio Feb 10 '12 at 13:16

2 Answers 2

Maybe you accidentally magnified your screen using Universal Access's screen Zoom, it can survive display detects with out zooming back out. And it can be accidentially triggered via holding down the key or some customizable key and then scrolling up or down with your mouse or track pad.

  1. Look in System Preferences under the "Univeral Access" section.

  2. Once there click on the "Seeing" tab. Is "Zoom:" on? If yes then continue.

  3. Press + + - to zoom out.

share|improve this answer

In System Preferences, select Displays. On each running display (i.e. both on the external monitor and the MacBook itself, should it be open) a list of supported resolutions will be displayed. Click "Detect Displays" on the dialog shown on the external monitor. This should make the system recognize the kind of display and the supported resolutions. You should then be able to change between these without problem.

share|improve this answer
    
I have the same issue and this didn't resolve the problem. –  Ignacio Feb 10 '12 at 13:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.