Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Previous to the update to iOS 5, the 'home sharing' feature in the iPad's iPod app worked as expected. You'd simply choose the different 'library', and you'd be able to play items over the network from that remote library.

This functionality seems to be missing in iOS 5 on an iPad 2 (and perhaps other iOS 5 devices?).

  • There is no way to choose a remote library or 'Sharing' in the Music app.
  • The same good Apple ID credentials are present in Settings, and has been re-entered just in case.
  • iTunes is running on the same Windows machine as previous. No changes have been made there (save for the new version of iTunes).
  • iTunes is running, Home Sharing is enabled.

How can this feature be restored in iOS 5?

enter image description here

enter image description here

share|improve this question
    
The "Shared" entry only shows up when the Computer holding the library is up and running. Did you consider this? –  patrix Oct 25 '11 at 5:32
    
I have the very same problem here. ALL steps have been followed. I can see my iphone 4s device in itunes over wifi, all creds entered, alas no "sharing" in the "More" section on Music. Any additional thoughts? –  Xepoch Nov 21 '11 at 17:21
add comment

7 Answers 7

up vote 6 down vote accepted

On the computer

  • Open iTunes
  • Turn on Home Sharing in the Advanced menu
  • Keep iTunes running

On the iDevice

  • Open Preferences
  • Open Music Preferences
  • Enter same AppleID for Home Sharing as in iTunes (note, you may have to re-enter the account if it appears already to be there. This both verifies the stored password is correct and re-registers the iOS device with your account's Home Sharing)

enter image description here

To Use

  • Start the Music app in the iPad
  • Tap on 'More' at the bottom right

enter image description here

  • Tap on 'Shared' to see a list of shares music libraries
share|improve this answer
add comment

I'm having the same issue, only my desktop machine is an iMac.

What worked for me was:
Under the "Advanced" menu in iTunes, there's a little item labelled "Turn On Home Sharing." Even though I had my Apple ID entered in Preferences, and the Sharing preference pane showed "Status: On," it didn't work until I found the item in the Advanced menu.

share|improve this answer
add comment

I tried everything, but what FINALLY worked for me was going to my main iTunes library and turning off home sharing. I then turned it back on, put in my credentials, and then clicked "create home share". It began working as described after that.

share|improve this answer
add comment

You have to make sure that your computer with iTunes and the iPad/iPod/iPhone device are connected to the same router. I have an Easybox router from Vodafone and my iPad was connected to that router. But this router has an Airport Extreme in bridged mode connected to it and that is where my iTunes was connected to. As soon as my iOS devices logged into the Airport Extreme, the button appeared.

I guess you need to enable certain ports for Bonjour to work on the Easybox...

share|improve this answer
    
Good point. It's probably not the router though but rather the DHCP server and the subnet which must be the same for Home Sharing to work. Are you sure your APExtreme is running in bridged mode? –  patrix Jan 2 '12 at 11:39
add comment

iPhone 4S, iPad 2, Home shares showing on other PCs on the network but not iOS devices. Tried everything above, yada yada no changes.

Solution: Check your wireless router settings. Specifically, Mulitcast Filtering

On a Linksys WRT610N, go to Security \ Firewall \ Internet Filter

Put a check beside "Multicast Filtering" and save settings No other changes required.

Restart your IOS device

"Shared" now appears under "More" button on both iPhone and iPad

share|improve this answer
add comment

Tried all the above. In the end having everything set on my iPad and iTunes and then turning router off and on. Then it worked!

share|improve this answer
add comment

Try enabling "Sound Check" in iPad's Music Settings. After this the "More"-button was shown on my iPad.

share|improve this answer
add comment

protected by Community Jun 20 '12 at 13:22

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.