Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Anybody else feeling this/have any idea how to fix it without reinstalling Snow Leopard? This seems very similar to problems PD used to have back in 2008 (forum link)

FWIW, my current network interfaces are: $ ifconfig -l lo0 gif0 stf0 en0 en1 fw0 vnic0 vnic1 vmnet1 vmnet8

(And yes, as you can see from the NICs, I also run VMWare Fusion 3.1.1, but the issue started upon upgrading to PD6)

$ ifconfig lo0: flags=8049 mtu 16384
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
inet6 fd18:d7ce:18ee:1e60:223:32ff:fea0:fade prefixlen 128
gif0: flags=8010 mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863 mtu 1500
ether HH:II:DD:DD:EE:NN
media: autoselect
status: inactive
en1: flags=8863 mtu 1500
ether HH:II:DD:DD:EE:NN
inet6 HH:II:DD:DD:EE:NN%en1 prefixlen 64 scopeid 0x5
inet 192.168.0.198 netmask 0xffffff00 broadcast 192.168.0.255
media:
status: active
fw0: flags=8863 mtu 4078
lladdr 90:84:0d:ff:fe:ba:6d:2a
media: autoselect
status: inactive
vnic0: flags=8843 mtu 1500
ether 00:1c:42:00:00:08
inet 10.211.55.2 netmask 0xffffff00 broadcast 10.211.55.255
inet6 fe80::21c:42ff:fe00:8%vnic0 prefixlen 64 scopeid 0x7
inet6 ::1 prefixlen 64
media: autoselect
status: active
vnic1: flags=8843 mtu 1500
ether 00:1c:42:00:00:09
inet 10.37.129.2 netmask 0xffffff00 broadcast 10.37.129.255
inet6 fe80::21c:42ff:fe00:9%vnic1 prefixlen 64 scopeid 0x8
inet6 ::1 prefixlen 64
media: autoselect
status: active
vmnet1: flags=8863 mtu 1500
ether 00:50:56:c0:00:01
inet 172.16.155.1 netmask 0xffffff00 broadcast 172.16.155.255
vmnet8: flags=8863 mtu 1500
ether 00:50:56:c0:00:08
inet 192.168.102.1 netmask 0xffffff00 broadcast 192.168.102.255

$cat /etc/resolv.conf
nameserver 208.67.220.220
nameserver 208.67.222.222

share|improve this question
    
Can you post the output of your ifconfig and the output of: cat /etc/resolv.conf (in Terminal.App of course) –  Martín Marconcini Oct 5 '10 at 14:38
add comment

1 Answer

up vote 1 down vote accepted

Start by making some tests in your Terminal:

1) Use nslookup and try to lookup certain stuff (www.google.com, www.ibm.com, etc) See how it works from there.

2) Use ‘dig’ (another command) to do the same. Dig will be much more verbose and will show you more information about the Lookup per se.

3) Make sure your DNSs are correct in /etc/resolv.conf (try google’s 8.8.8.8 if unsure).

4) Check your Console for possible messages related to Network adapters or loops going on.

Edit it all seems “normal”. Do you use Shared networking? Can you try disabling vnic0 and vnic1 (those are the parallels ones). I recall having slowness problems (back in parallels 3.x) which I fixed by using Bridged Networking instead of shared. I didn’t think the issue was still an issue a few years later!

share|improve this answer
    
1 and 2) It sometimes resolves immediately, other times sucks as hell. That is what's so baffling. I actually ran "time nslookup" and "time dig" commands and I get weird behavior. 3) My DNS servers are definitely correct. I use OpenDNS because I want Google to at least not know all my porn habits. 4) I do see some weird kernel.log messages with VMWare info... (vmnet: VMNET_SO_BINDTOHUB: port: paddr vmnet: bridge-en1: media 80 dev 0x89f2404 family 2vmnet: Invalidating peer info for hub: 0, port: 0vmnet: VNetUserIfFree: freeing userIf at 0x9e8df00.) I'll have to look into this more. Thanks! –  intlect Oct 5 '10 at 16:37
    
I too, use OpenDNS so try to disable all the virtual adapters provided by both Parallels and VMWare and start one by one. Bridged networking usually works best (for me) as it creates a “real” adapter (virtual anyway) and doesn’t mess with the creation of a “private network” between your Mac and your VMs. –  Martín Marconcini Oct 5 '10 at 16:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.