Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a new iPod Touch, and an old(er) Mac. To connect my iPod Touch to the internet at home, I set up my Mac to share its internet connection (ethernet) over wifi.

I'm running Mac OS X 10.5.8 on an Intel (Core 2 Duo) Mac. For completeness, the "sharing" control panel says:

Share your connections from: Built-in Ethernet
To computers using: (X) Airport

and the Airport Options say:

Network Name: (some name)
Channel: Automatic
[X] Enable encryption (using WEP)
Password: (some 5-letter word)
Confirm password: (again)
WEP Key Length: 40-bit (more compatible)

I used this setup for a couple weeks with no problem at all. A day or two ago, sometime in the afternoon, it got funny: the connection would work for a few seconds just fine, and then cut out for a few seconds, then come back, etc. Sometimes I can sit here with my iPod and watch the network status icon at the top of the display come and go.

It's not a strength issue: I'm right next to it, and it always shows max bars in the iPod control panel. It's not a WEP issue, because it accepts my password, and if I turn off WEP entirely it does the same thing. If I'm in the iPod control panel, it always shows max signal strength for my network -- it just disconnects me regularly, and frequently. (This is especially annoying if I go into an app like Safari, because it asks me to pick a network and retype my password every 10 seconds.) It's not an iPod issue, because the wifi still works perfectly on all other wireless networks I use.

Has anyone seen this before? I haven't tried rebooting yet because I have a ton of things open. Is there some way to restart the networking subsystem on Mac OS that might help this?

share|improve this question
add comment

1 Answer

I suggest you restart your box to make sure that it’s just not a problem there. You could technically turn off the AirPort and turn it back on (that’d restart most of the stuff), however the “problem” could be on the Kernel level, which would only be fixed with a proper restart or even a hardware buffer, which a cold shutdown would most likely fix.

In any case, if you still want to experiment, try changing the Channel from Automatic to something you can use in your country and move it, maybe somebody (neighborhood?) brought new devices or networks next to you and that causes new interference that wasn’t there two days ago.

share|improve this answer
    
I have since tried (1) setting the channel to a fixed value (and back to auto), (2) turning wifi off and on again, and (3) rebooting. The problem persists. :-( –  Ken Oct 7 '10 at 5:57
    
I've since given up and bought an Airport Express. It works flawlessly, with no special wifi configuration, which suggests the problem was not with neighborhood interference. –  Ken Nov 6 '10 at 21:31
    
@Ken well, the signal strength of the AE is superior to anything a Mac can produce with its internal Wi-fi card/antenna. Glad to hear you have it working tho’- –  Martín Marconcini Nov 6 '10 at 22:08
    
I really don't think signal strength has anything to do with it. I can hold my iPod 6 inches away or on the other side of the building, and still get full bars and full speed right up until the second when it drops out completely. Also, when my Mac's wifi gets flakey because of weak signal, its failure mode is not "full bars/speed for 2 minutes, no connection at all for 30 sec, full bars/speed for 1 minute, etc". It's only when acting as a base station that it likes to cut out entirely from time to time. Signal strength also wouldn't explain why it worked perfectly for 2 weeks. –  Ken Nov 7 '10 at 3:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.