Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm amazed I can't figure this out - my friend has an iPad running iOS5. He can send me an iMessage to my phone using my AppleID. But (outside of replying to his message) there is no way for me to send him a message using the Message app, since it only lets me enter phone numbers.

So, how does an iPhone user send an iMessage to an iPad user's AppleID?

EDIT: Does this work for anyone else? ON AN IPHONE (3GS, if it matters, running iOS 5), open Messages. Hit the 'Compose' button. Try to type in an email address in the 'To' field.

There is NO WAY to enter an email address there, afaict

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

How does an iPhone send iMessages to iPad:

  1. Make sure iMessage is set "on" on both devices
  2. On your iPhone, go to Contacts and find your friend's name to check whether or not you have his email address. If not, you need to add his email address.
  3. On the iPad, go to settings>>messages>>recieve at>>add email. Put your friend's email address from step 2. It will say "verify".
  4. Your friend need to verify by checking his email. There'll be an email from Apple. Open the email and he'll be asked to click on the verify link. Click on it and he'll be directed to Apple's homepage. Just follow the instructions there.
  5. Once your friend has verified his email address, the word "verify" in step 3 disappears. Now you can iMessage him.
  6. On your iPhone, go to contacts and choose your friend's name. Click on "send message" and choose the email address that was just verified. You're now directed to the message screen.
  7. In the "To" field, you 'll see that the email adress is missing "@". Ignore it.
  8. Make sure that the send button is blue. Now just type your message and send.

Hope this works!

share|improve this answer
1  
That works - it's amazing that Apple would make it so complicated. If you select the friend's email address, it does NOT work. You must select 'Send Message' and then choose email, like mentioned above. Also, the fact that '@' doesn't appear is an amazing bug. –  psychotik Oct 20 '11 at 1:48
add comment

psychotik, I think I figured this out. I was having the exact same problem as you. There was no way to type an '@' sign, and selecting from the contact list inside Messages app only shows phone numbers. I had to turn on "MMS Messaging" in Settings > Messages.

This enabled the @ sign on the keyboard for me. See:

user's keyboard

I have no idea why this affects it. I feel like MMS should have nothing to do with whether I can iMessage someone, but it works for me, so I won't complain.

share|improve this answer
    
Seconded. When I enable MMS as suggested, the available selections for a contact include their email addresses, which will hook you up with iPad-only users. –  Clay Bridges Jan 13 '12 at 17:52
add comment

First make sure iMessage is turned on on your iPhone; then just create a new message and in the “to” field write your friend’s iMessage address. When you type it all the title bar should change from “Message” to “iMessage”.

share|improve this answer
    
Huh? Did you just type that answer thinking you know how this works, or have you actually tried this? There is no iMessage app on the phone - it's rolled into 'Messages'. Also, you can't just 'write your friend's address' in the to field -- there is no '@' character available on the keyboard. Copy-pasting doesn't work (it removed the '@') and you can't pick an email address from a contact. –  psychotik Oct 19 '11 at 18:13
    
Works fine here as Samantha suggests. –  Jim Oct 19 '11 at 18:19
    
@psychotik I tried it just yesterday on my friends iPhone, she's been iMessegeing me ever since. And I'm sure they are iMesseges and not normal texts because I only have an iPad –  Samantha Catania Oct 19 '11 at 20:40
    
Also I had no troubles finding the @ on the keyboard –  Samantha Catania Oct 19 '11 at 20:42
1  
I also didn't say make sure iMessege is on your iPhone but make sure iMessege is on on your iPhone i.e. you have to turn it on –  Samantha Catania Oct 19 '11 at 20:43
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.