Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Having an issue where I have a folder on a QNAP NAS with over 68,000 subfolders within it.

I can browse it quickly and almost instantaneously within Windows 7 via SMB, however in OSX 10.6.8 and 10.7.2, it takes nearly 10+ minutes to display the subfolders, using both SMB and AFP.

Hoping there is an easy solution - we can't break the folders into smaller subfolders due to a requirement of proprietary software that accesses the sub folders.

I've tried the fixes suggested here, which don't seem to help: http://www.macwindows.com/snowleopard-filesharing.html#030311b

Have the same issue browsing the files on a Windows 2003 server, so it is not a NAS issue - rather, it's an issue with how OS X browses over the network. Perhaps it is trying to cache all the files/folders before displaying them?

Windows 7 doesn't do this, and therefore the subfolders display almost immediately.

share|improve this question
    
What version of the QNAP firmware are you running? The latest firmware has some good fixes for AFP specifically. I've noticed significant increase in speed of access. –  Digitalchild Oct 25 '11 at 8:40
    
Thanks - forgot to mention that I'm running the latest v3.5.1 Build1002 –  Josh Newman Oct 25 '11 at 20:09
    
Hmm I've got the same firmware and its working fine. Are you able to ssh to it and see if anything is chewing processes ? –  Digitalchild Nov 8 '11 at 6:05
    
Have you ever solved this issue? This has been bugging me from day one. –  Aron Rotteveel Feb 23 '12 at 15:50
    
@AronRotteveel nope, still appears to be an ongoing problem. –  Josh Newman Feb 24 '12 at 17:32

2 Answers 2

try to relaunch your finder, some of my colleagues got improve after this. if in same lan, some computer fast and some slow.

share|improve this answer
1  
Can you add some detail on how Finder can be relaunched without logout/login? –  patrix Aug 8 '13 at 8:57

I, too, find this a pain with my QNAP box. FYI the firmware has now been updated to 3.6.0 released just a few days ago, and there is some noticeable improvement with the update. However, you may consider using the iSCSI feature among the QNAP settings to make the file shares appear as a hard drive showing up on your desktop for better speed. I've noticed iSCSI works better IMO if your connection to the QNAP is hardwired throughout and not wireless in any way; wireless iSCSI works, just not as fast in my experience.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.