Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just got the iPhone 4S, and it seems like my email is polling rather than push. I set up my Gmail account, and emails do not come to my phone instantly. It appears to be polling, rather than pushing. I see, on average, about a 10 minute delay between when I see my email in my browser and when it comes to my phone.

Does Gmail push on this device, or have I set something up incorrectly?

share|improve this question
1  
Seems like the best option at this point is Google's GMail app for iOS. –  daviesgeek Oct 26 '12 at 5:19

4 Answers 4

up vote 14 down vote accepted

If you setup your Gmail account as IMAP, it is not pushed. If you setup your Gmail account as an Exchange account, then it will be. The instructions on how to do this are found on this page. Hope this helps.

share|improve this answer
    
This is what I do. The only problem with doing this is that the iPhone has no concept of Gmail's Archive function when the account is added as Exchange. You will have a trashcan icon that will "delete", but Gmail's servers will treat that as an archive. Manually moving messages from the Inbox folder to the Trash folder on the iPhone interface also doesn't work. The only way to delete a message is to log into the web interface and delete it there. All other actions will simply archive it. –  Bryson Oct 17 '11 at 19:37
    
That is in fact a terrible feature, I agree; and it is one of the reasons I stopped using Gmail. Google has chosen to implement their server Deletes as Archives (rather than follow the standard) because it is in their best interests to keep as much as your information as possible. Having said that, the original question you had was about Gmail being pushed or not, and technically it is pushing its data once you set it up as Exchange. The Delete as Archive issue is not a fault with Exchange or iOS, but an intentional design decision by Google. My office Exchange deletes as you would expect. –  Christian Correa Oct 17 '11 at 20:17
2  
You can go to m.google.com/sync from your iPhone to control the behavior of delete in Exchanfe configurations. –  Phong Sep 11 '12 at 20:40
    
That Google support page is down –  James McMahon Mar 23 '13 at 15:21

In iOS 6, I changed my Google accounts setup from Exchange to IMAP to test them, and I think they're not compatible with Push. If you go to "Settings", and then to "Mail, Contacts, Calendars" inside iOS, you can go to "Fetch new data" to enable Push, but, if you go to "Advanced" (within "Fetch new data"), you can see, one by one, how iOS will get mail from each account, and only the iCloud account is Push enabled, but not the others, so the only option is to set them up using Exchange method :(. The weird thing is that, in Mountain Lion, using the default Gmail method, you get push email, so I don't understand it yet :(

Here's a guy explaining the problem and the Exchange method: http://www.youtube.com/watch?v=g107DStzN8Y

share|improve this answer

Pushing works out of the box for

  • MobileMe
  • iCloud
  • Exchange
  • Yahoo!

With Google you have the option to set up the account (on your iDevice) as an Exchange account which then gets pushed as well. Setting it up as Gmail gives you polling (like all other providers).

share|improve this answer
    
Incorrect. Exchange accounts also get push, and have for a long long time, and Google enabled adding gmail accounts as Exchange for iPhones. –  Bryson Oct 17 '11 at 19:35
    
Hotmail (which I assume is a variant on Exchange) also pushes. –  Hand-E-Food Oct 17 '11 at 22:20

The push feature doesn't seem to work for emails to which you have rules created for. For example, when I created a rule that transferred all emails from X sender to a specific folder - Outlook will create a folder and Gmail will create a folder/label but this doesn't get pushed to my iPhone - it appears that only emails in the main inbox get pushed. I made sure that all folders get pushed in my exchange email settings too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.