Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After upgrading to iOS 5 my AppStore language changed to German. Referring to that quesiton it is possible to change the language by selecting the country in iTunes like it is described in this apple KB.

My problem is the following : I have a Swiss AppStore account, as you may know Switzerland has many official languages (German, French, Italian, ...) that why a Swiss AppStore account could be in German, French or English as default language.

Before upgrading to iOS 5, the AppStore language was in English as I want it.

I've tried the solution given by the Apple KB. But even doing so, you can only select the country but not the language (German is the first language in Switzerland, that's why it falls back to german). By the way, when I go to the iTunes store the language is also German.

I have tried to set English as default language in the following places :

  1. iOS's language in ENG
  2. iCloud.com account in ENG
  3. MacOSX Lion's language where I have my iTunes in also ENG

Where can I specify the language so the AppStore & iTunes Store language will be in english ?

share|improve this question
    
Try logging out of the store, rebooting the device, and then logging back in. –  cksum Oct 17 '11 at 9:20
1  
Nope, it didn't worked. Still in German –  Kami Oct 17 '11 at 9:38
1  
I thought all Swiss citizens would speak German :) –  Studer Oct 17 '11 at 12:26
    
Same issue ... After migration to iOS 5.0 the AppStore, iTunes and Reminders apps are now localized in German (I'm Swiss but would like the applications to be localized in English) did you find any solution? –  user13246 Nov 4 '11 at 22:31
1  
@Studer No and even if everybody would, Apple could come over the closed US mentality and realise that not every country is as the USA. As a native Italian speaking Swiss citizen I found really stupid that I need an Italian account to watch moves in Italian (the Swiss store offers just a small bunch of them). Apple.ch is also only available in DE/FR ... No comment –  Matteo Dec 16 '12 at 9:53
add comment

1 Answer 1

Settings -> General -> International -> Language -> Make sure it's set to English.

If this doesn't work, SYNC to your computer and see if it goes back.

share|improve this answer
    
The language of the system is ignored by the iTunes and App Stores on iOS –  David Pearce May 26 '13 at 4:18
add comment

protected by Community Jan 5 '12 at 18:23

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.