Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried several times with several backups, but i keep getting the message that the backup is corrupted or not compatible.

share|improve this question
I thought that was what happened after I had to use the restore function to upgrade to iOS 5 on my iPhone and iPad. Immediately after rebooting after upgrading, it asked if I wanted to restore a backup, and then proceeded to do so. – Lasse V. Karlsen Oct 16 '11 at 14:40
That's what I did and it worked for me without problem (or error message) – poupou Oct 16 '11 at 15:25
thanks for your answers. it is strange, indeed: i keep getting the same error message! – guilherme Oct 16 '11 at 20:54

After the restore fails, take a look at the phone and see if your data is installed.

Restoring data after every major iOS update has failed on me, but after I put the apps back on, all my data is there. Pick a few apps that you know contain data (Contacts, games, documents, Notes, login details) and see if your data has at least been restored.

It takes some time to put the apps and usic back on, but major iOS updates only happen once every couple of years.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.