Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

The sender id as it displays on the recipients iMessage is what I would like to reset. However, I cannot find where it is set on the sending device (iPhone 4). It seems to be device dependent as sending iMessages from my iPad 2 displays a different sender name although both devices use the same Appleid.

share|improve this question

2 Answers 2

I'm pretty sure that it's set in the contact for that person's AppleID/Email Address. Take a look in that persons info in

share|improve this answer
I may not be asking my question clearly. I am trying to modify the name the message recipient sees when I send them an iMessage. If I send someone an imessage from my iPhone, the recipient sees it as coming from DANI. If I send the same person an iMessage from my iPad 2, they see it as being sent by Bill. – Bill Oct 15 '11 at 21:27
@Bill I'm going to assume it's the same iCloud account. In that case, it's probably buried in the iCloud account settings. (same as your Appstore) – James Oct 15 '11 at 21:54
Hmmm. Yes, same iCloud account. I upgraded both devices to ios5 within an hour of each each other but never specified any names for the devices. They have to be buried somewhere in the device but I can't figure out where. – Bill Oct 16 '11 at 11:36
Have you looked into the other person's phone? Maybe he has your email saved as both Bill et Dani. – Loïc Wolff Oct 20 '11 at 11:59

I hope I understood your question correctly. Try this: go to settings>>messages>>caller id. Choose the email address that is associated with the name you want the recipients to see

share|improve this answer
Yep. If you set it to the Apple ID (or associated email address) you want to use, that'll be the "from" in every iMessage you send, and before long your iMessageable friends will be automatically configured to reply to that rather than to your phone number. – Dan Ray Oct 20 '11 at 12:27
I have an old IPhone and when I go into Settings>messages> it does not show CallerID but show preview or repeat alert or MMS Messaging or show subject field (they are all On and Off buttons Where do I go now? – user112631 Feb 5 at 20:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.