Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just upgraded to iOS 5 and am having trouble with the automatic sync to iTunes. Sync works fine if I go into Settings -> General -> iTunes Wi-Fi Sync and press "Sync Now" or trigger the sync from the Device menu in iTunes, but when I plug in my phone overnight sync doesn't happen.

Am I forgetting a setting? Or is there a known-issue that I haven't been able to uncover?

My setup:

  • iPhone 4 with iOS 5
  • iTunes 10.5 on MacBook Pro running 10.7.2
  • Time Capsule for Wi-Fi

EDIT: For clarification, I do have the "Sync with this iPhone over Wi-Fi" checkbox enabled in the Summary screen, and the prevent syncing box in Preferences is not checked.

share|improve this question
    
What about the setting in iTunes that says "Prevent iDevices from syncing automatically" Under settings>Devices? –  user12433 Oct 19 '11 at 17:22
1  
Is the device set to back up to iCloud? I think that disables the automatic wifi sync. –  robmathers Nov 3 '11 at 5:27
    
@CanuckSkier wait what? that may be my problem ... –  jcolebrand Dec 22 '11 at 3:36
    
@jcolebrand my phone started syncing automatically after following the steps in the accepted answer, and I have iCloud backup on still. It does fail sync every now and then if I have a large app that needs to be updated (timeout maybe?) but it works more times than it doesn't. –  Ryan Ahearn Dec 22 '11 at 15:47

3 Answers 3

up vote 7 down vote accepted

I had a problem with AUTOMATIC wifi sync not working. Wifi sync worked when initiated from my iphone, but there was no automatic sync.

The fix I found was to:

  1. Ensure "Enable Wifi sync" in checked in the iPhone summary page of iTunes
  2. Ensure "Open iTunes when this iPhone is connected" is checked in the iPhone summary page of iTunes
  3. Ensure that "Prevent iPods, iPhones and iPads from syncing automatically" is not checked in the Preferences - Devices settings of iTunes.

I was missing step 2. Once I checked this box, I gained automatic wifi sync every time my iPhone was connected to external power within range of my wifi network.

share|improve this answer
    
did all these and still not seeing automatic syncing when iTunes is open and my phone is on the charger –  jcolebrand Dec 22 '11 at 3:33
    
The “Open iTunes when this iPhone is connected” was crucial for me. I had this turned off and the devices never synced automatically although iTunes was always running on the same network. –  Rafael Apr 2 '12 at 7:48

I have the similar issue.

Please try these: http://artoftheiphone.com/2011/10/16/troubleshooting-automatic-wi-fi-syncing-for-iphone-or-ipad-not-working-heres-an-alternative-solution-to-fix-it/

I actually notice --- even after I do this, it still does not sync automatically. So I enable this option "Open iTunes when this iDevice is connected" (in the options setting for the device --- just above the "sync with this iDevice over WiFi" option).

Then it starts to work.

share|improve this answer

This feature needs to be set up in iTunes. Connect your device. In iTunes, select the device and look on the Summary tab. At the bottom of the Summary tab is the Options section. Check the box next to "Sync with this iPhone over Wi-Fi." Now it should automatically sync wirelessly when connected to a power source within range; or, you can manually sync wirelessly through the Settings > General > iTunes Wi-Fi Sync menu.

I also was under the impression this was automatic, but I guess it makes sense to have it as an option.

share|improve this answer
2  
I do have that box checked, which is why syncing manually works. It has not yet ever synced automatically when plugged into a power source though. –  Ryan Ahearn Oct 16 '11 at 15:27

protected by Community Oct 20 '11 at 22:43

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.