Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a Spanish layout keyboard (in Snow Leopard). Whenever I use the dot, or comma, in the numeric keyboad (right of the 0) it always shows a comma, but I'd prefer if it entered a dot, just like PCs do. Otherways, entering IP addresses, or decimal numbers when coding is a PITA. How can I do that?

I have tried altering my regional settings so that the decimal separator is a point and the thousands separator is a comma, but that doesn't seem to affect text entry.

I'd prefer changing some regional setting rather than remapping the keyboard, but I'll accept any answer that works - short of changing the regional layout of the keyboard, I really need my diacritics there.

share|improve this question
    
I prefer to keep the title as I originally intended. I don't want to disable it, just configure it differently, and possibly use a modifier key to use one or the other. –  Victor Jalencas Aug 25 '11 at 15:33

7 Answers 7

up vote 4 down vote accepted

You need to change the layout of your keyboard. Not to another one, but to a new one that has been modified by an utility like Ukelele (there might be others).

Download the tool, drag the App to your Application folder. Notice that in the Disk Image, there’s a folder called System Keyboards/Roman/, copy that to you desktop (it’s temporal).

Launch Ukelele and from the File menu select: “New based on…”

Open the file Spanish-ISO.keylayout (found in the Roman folder that you saved to your desktop).

You’ll see a big blue keyboard representing your current Spanish-ISO map (if you brought your computer in Spain, that’s they keyboard you should use).

Double click on the “,” that you want to modify (or any other key) and you’ll see this:

Edit in Ukelele

Replace the “,” with the “.” (dot). And go to Keyboard Menu -> Set Keyboard Name. Rename the Spanish - ISO to something like: Spanish - ISO2.

Now save it, the name will be Untitled, but you should put Spanish - ISO2.

Where do you save it?

According to Ukelele’s User Manual, you have different choices (and I suggest your read section 3.3 of the manual). Short answer is within the Keyboard Layouts sub-folder of the Library folder in your home folder. This can be created if it doesn’t already exist. If you do that, only your user will see (and be able to use) this Layout.

After installing the keyboard layout and logging out and logging in again, open the International pane of System Preferences (Language & Text on Mac OS X 10.6 (Snow Leopard) and later). On the Input Menu (Input Sources in 10.6 or later) tab, your new keyboard layout should be listed there. Enjoy your faster IP Address typing.

share|improve this answer
    
Thanks. In the end, I just used the keyboard layout provided in the disk image and edited it by hand. I wonder why these layouts are not provided with the system (or are they?) –  Victor Jalencas Oct 11 '10 at 8:47
    
Hmm They are, only not in an "easy to use disk image” ;) –  Martín Marconcini Oct 11 '10 at 9:56
    
Yeah I suppose they are somewhere, but not in any Keyboard Layouts directory. –  Victor Jalencas Oct 11 '10 at 13:47
1  
Keyboard layouts saved in ~/Library/ aren't selected by default in password dialogs, but ones saved in /Library/ are. The character picker popovers only work with keyboard layouts saved as bundles. –  ؘؘؘؘ Oct 13 '12 at 3:28

Just discovered an alternative solution, and at least for me a much better one, which does NOT require keyboard remapping and works on other people's macs too:

press shift when you press the comma on the numeric keypad, it will be entered as a point (at least in snow leopard (osx 10.6))

(As I have a Belgian keyboard layout, I've used the keyboard remapping solution [using Ukulele] for some time, but it didn't play well with all applications, e.g. Eclipse)

share|improve this answer
    
I very much would prefer this solution. But for some reason it doesn't work on the Spanish layouts, but it does on the Belgian. I'll fill a Radar and see what happens. –  Victor Jalencas Aug 28 '12 at 14:11

David's answer was extremely helpful! Give a try to KeyRemap4MacBook

The app is clumsy & little buggy but does the job.

On my Spanish - ISO keyboard layout had to enable/change:

  • KeyPad-Dot(.) to Command+X (Cut) with Italian (What?)
  • KeyPad Comma(,) to Dot(.) on "Italian Pro Input Source"
share|improve this answer

KeyRemap4MacBook solves this problem as well, without having to set up a completely different keyboard layout in Ukelele. Simply enable the "Swap Dot and Shift+Dot" option in the "Change Keypad Key" section.

share|improve this answer

I use the app Better Touch Tool that allows you to do so all sorts of customizations with gestures and the keyboard. I just added a keyboard assignment that essentially mapped shortcut "pad ," to "." and it works perfectly.

share|improve this answer
    
Welcome to Ask Different! Could you expand on how you used the aforementioned app to achieve this? –  grgarside Sep 7 at 15:14

You can also use a tool like Keyboard Maestro. I’ve set it up like this:

  1. Triggered by: The Hot Key Key Pad . is pressed
  2. Action: Insert Text ‘,’ by Pasting

It works surprisingly fast without having to create a new keyboard layout or remap keys.

share|improve this answer

Ctrl+, (just for the comma in numeric keyboard) yields to a . (dot) when in spanish layout.

Oddly enough this works in terminal and in some text editors (like textwrangler). MacVim, for instance, just renders a . when using , in numeric keyboard. And TextMate just ignores this modifier and prints a ,

... You know, the good thing about apple stuff is that it "just works".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.