Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Interesting problem I can't find anything about: I have my iPad synced with my personal MacBook. Backups work, as far as I can tell (list of backups in Preferences window), and apps update, etc.

When I try to update to a new iOS or attempt to restore, it fails. I get a general error that the device "is not eligible for the requested build." I get referred to http://support.apple.com/kb/TS1275, which isn't very useful. I first notice this with an update to iOS, I think 4.3.4. It happened again with 4.3.5, and now with 5.0

No manner of DFU or Restore mode has successfully worked to resolve this. With the first occurrence, 4.3.3 -> 4.3.4, I took it to the apple store with my computer (key point), we tried all sorts of modes without luck. Then, we tried with an Apple Store system. Worked! Subsequent upgrades also required a use a different system, I've been using my work Air. This is annoying because of the warnings that the iPad is synced with another device, you have to lose everything to sync with the updating computer, then do the same again after update back with the personal computer.

Something is wrong with my local iTunes on my personal system, and I can figure out how to get around it. Any thoughts?

First gen WiFi only 64gb iPad. Current iTunes, System Update at the time of upgrading iOS. No issues with iPhone.

share|improve this question
    
And after looking at a suggestion for someone else's problem that hosts might be messed up, i saw a redirect that looked fishy. fixed! I can't add this answer for 7 hours, but of course i resolve the issue after writing a lengthy post. –  greenwar Oct 14 '11 at 15:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.