Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Yesterday I installed Mac OS X 10.7.2, iOS5, and set up my iCloud.com account. I entered my iCloud details in System Preferences in Mac OS X, and in Settings on iOS. In both places, I set calendar syncing to “On”

However, I just created a test event in iCal, and it didn’t sync to iCloud.com or iOS. Events created on iOS sync to iCloud and iCal just fine.

What’s going on?

share|improve this question
    
Everything on my iCloud is now double synced on my iCal but it still doesn't go the other way. iCal events don't show up on iCloud. –  user13467 Nov 9 '11 at 19:25
    
@Sarah: did you set your default calendar in iCal preferences to one of your iCloud calendars? –  Paul D. Waite Nov 9 '11 at 20:28
add comment

2 Answers

up vote 2 down vote accepted

It turns out I had to:

  1. Add my iCloud account to iCal, in iCal > Preferences > Accounts.

  2. Set my default calendar to one of my iCloud calendars, in iCal > Preferences > General.

See e.g.

It seems a bit strange that I had to do this manually — you’d think just turning on Calendar syncing in the iCloud preference pane would do it.

share|improve this answer
    
Not everybody wants everything synced "to the cloud" –  EmmEff Oct 14 '11 at 14:03
    
@EmmEff: sure. I think iCal is preserving my existing calendars on my Mac, and has created copies of them on iCloud. As long as I set iCal to edit the iCloud calendars, everything gets synced. –  Paul D. Waite Oct 14 '11 at 14:31
    
@EmmEff: And as you say, the way it’s set up means I can still maintain other calendars within iCal that don’t touch iCloud. –  Paul D. Waite Oct 14 '11 at 14:38
    
I ended up having some calendar strangeness as well and re setup everything to make sure it was correct. –  EmmEff Oct 14 '11 at 15:09
    
@EmmEff: yeah, I got a bunch of duplicate events (or it seemed like I did). Syncing is hard. –  Paul D. Waite Oct 14 '11 at 15:25
show 2 more comments

I changed my "Refresh" settings in iCal preferences from "push" to "every five minutes." For some reason, this got things moving again and started syncing.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.