Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

The Problem:

I've just updated to OSX 10.7.2, with iCloud support. Everything works fine. Except... when I try to enable 'mail and notes' under iCloud settings, it just gets stuck displaying 'starting'.

If I go to my mail app, I am greeted by the message

Cannot send mail, failed to connect to the iCloud server.

When I try to use mail from iCloud.com, I am greeted by the message

To use iCloud mail, create an @me.com email address by turning on mail in your iCloud settings, using iOS or OSX.

However, I am never prompted to create an @me.com email address when I turn on mail in iCloud settings.

-

What might have caused the problem:

A couple of months ago, I reserved my @me.com email address by creating it on my brothers laptop (because he's a developer). In fact, I can even log in to iCloud using this email address.

So basically, some part of Apple's database believes I have an @me.com address, but the mail portion of iCloud doesn't think this is the case and still wants me to create one.

-

I'm pretty stuck on this - any ideas or suggestions would be much appreciated.

-

Edit:

I had some ideas on a couple of things that might fix it, but don't know where to start on them.

  • Do iCloud settings have an associated .plist file? Sometimes deleting/modifying .plist files can solve problems. I've had a look for one but couldn't seem to find one easily - if there is one, where might it be located?

  • If anyone else has this issue, what happens when you try using iCloud mail from an iPhone/iPad etc?

  • Apple support is impossible to contact if you're out of the phone support period (I'm still under warranty though). What ways might I be able to contact Apple, in case it's an issue with their database? Could I file a bug report somewhere, or send an email to some hard to find email address?

share|improve this question
    
I have the exact same problem, but the why. I used to have a paid subscription to MobileMe, and it gave me a @me email. I stopped paying for the subscription but still could use the Apple ID to access Itunes and stuff. I now have Lion and upgraded to iCloud, but have the same problem with email. –  user12302 Oct 18 '11 at 4:53
    
Same here. Used the MobileMe trial and it ran out some months ago. As a developer I had access to iCloud, but Mail never worked. Turned the settings on and off for a couple of times already on iPad and Lion. –  Patrick Oct 18 '11 at 7:49

4 Answers 4

You may just need to wait.

I transferred my MobileMe account to iCloud on iOS 5 launch day. I encountered the same issues that you seem to be having in that when I tried to use the mail app on iCloud.com it gave me same error message as you received. When I tried to turn mail and notes on in the iCloud system preferences, it just hanged on 'starting'. All other features were working correctly.

I just trumpet it up to high demand on Apple's servers and decided to wait. I just tried now and my email is working from both iCloud.com and mail.app.

share|improve this answer
    
Been seeing a lot of this with a lot of my friends lately. –  hobs Oct 19 '11 at 5:00
    
Thanks, still hasn't changed after more than a week though. If I still need to wait then that's pretty slack on Apple's part! –  Jordan Oct 22 '11 at 5:54

I know it is silly, turning mail ON from settings->icloud solved the issue for me.

icloud

share|improve this answer
    
Like I said in the original question, it gets stuck displaying 'starting'. It isn't the solution, I've done this a million times already. I think your problem was that you never turned on mail in the first place, the issue here is that mail won't turn on no matter what is tried. –  Jordan Oct 18 '11 at 8:48

I had similar issues initially with two AppleIDs where one of them was defined as the alternative address for the others. Finally I used https://appleid.apple.com/ to clean out these issues. Might be worthwhile to try with your mac.com/me.com addresses/IDs as well.

share|improve this answer
    
This doesn't seem to be the problem. Have played around with associating/unassociating my Apple ID email and the iCloud email I created a few months ago... doesn't change anything. Thanks though :) –  Jordan Oct 24 '11 at 1:54

After digging through the support forums for a few hours it seems that this problem is known and that there is still no general solution. The only way to solve this right now seems to be to use an ios 5 device. This probably means that this bug is in lion icloud preference pane. If you can get your hands on an ios 5 device try setting up from there. You can also use a friend's device and delete the account data when you are done. Your friend will be able to log back in to his own account with no problem.

share|improve this answer
    
Ok thanks, will try this soon. –  Jordan Oct 23 '11 at 3:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.