Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Time Machine running on an external hard drive and it reports happily that it is doing backups and I have no reason to doubt it.

But when I try to look at the backups by clicking "Enter Time Machine" nothing at all happens. No noises from the disk as far as I can tell. Nothing. And when I locate the "Time Machine" app in the Applications folder and run that, again, nothing happens...

Do you have any idea what is up or what I need to do?

share|improve this question
I assume you rebooted already. Do you see anything special in the logs (via Can you access the TM drive in Finder? – patrix Oct 14 '11 at 16:24
Yes I rebooted. I also unmounted, disconnected and powered off the drive. Then I deleted preferences in /Library/Preferences. Then I rebooted, connected and powered the drive back up and configured Time Machine anew. It is now happily conducting it's backup but still the Enter Time Machine command doesn't do anything... Weird. – pitosalas Oct 14 '11 at 16:37
Any log messages in – patrix Oct 14 '11 at 17:22
None that are related and time matched with when I try to do the "Enter Time Machine". Here is all of today's logs with the word "machine" in them. Looks like its happily doing a backup. The only quasi unusual thing is where TMSafetyNet is mentioned. But is not in sync with when I do the command. (My log is in the next post because of capacity of comments.) – pitosalas Oct 14 '11 at 20:46
I did one more experiment. I created a brand new account and logged into it. Time Machine "Enter Time Machine" command still does nothing. The screen doesn't change, the disk doesn't make noise... THis is a total stumper that no-one seems to have any kind of clue... :( – pitosalas Oct 16 '11 at 14:48
up vote 7 down vote accepted

By the way, I solved this:

THe external drive contained an existing backup to the same computer called *.sparsebundle. Those are only made when a drive is being accessed by Time Machine over the network. It was there from before I moved it to attach directly through USB.

TM was able to access that sparse bundle without errors and update the backups there which is why my backups were running correctly.

However for whatever reason, when I try to enter TM to see the backups it did "nothing". No messages, windows, or errors of any kind, including in the system logs.

The solution was to delete that sparse bundle and do a new backup with the drive directly connected via USB. This created a folder called *.backudb as expected, and now I can do backups there and I can see the backups by entering time machine (taking me to the time travel window.)

Ouch. I say the fact that this happened without any error message is a time machine bug although probably not many people hit it. At least give an error, but better, just work with the .sparsebundle, why not?

Remark: you can still access the backup data by opening the backup via the Finder. This doesn't give you the fancy star spangled background, but you can at least access your files.

share|improve this answer
Thank you! Deleting the sparsebundle solved my problems with Time Machine not creating backups, and with Migration Agent not recognizing my latest backups when I tried to transfer files from the time machine to a new Mac running Mountain Lion. – Noah Sussman Feb 22 '13 at 16:52

I had a similar issue where Timemachine backups were getting done successfully on my networkdrive, but "Enter Time Machine" was not working.

After several backups deleted, what finally worked was to install all pending Software Updates and it worked!!

share|improve this answer

A better workaround than pitosalas's answer of creating new backups is to use a symlink in the existing sparsebundle.

  1. Connect the USB Drive
  2. Mount the Time Machine Sparsebundle by clicking on it or using diskutil
  3. cd /Volumes/USBDrive/
  4. ln -s ../TimeMachineSparseBundleDrive/Backups.backupdb

Voila! It requires you to manually mount the sparsebundle disk each time before using GUI Time Machine, but it works.

share|improve this answer

I had this very same problem, but it transpired to be an access permissions issue.

Situation: Timemachine backups to a ReadyNAS Duo connected to the router. System backing up without any problems. Only one user account (admin).

Clicked on 'Enter Time Machine' or the Time Machine App logo to view the backups content and nothing happened (exactly the same as initial problem stated above).

I could see the a HardDisk image on the desktop called "Time Machine Backups" - contained only one folder "backups.backupdb" (nothing referring to 'sparsebundle'). Inside the backup folder was a single folder with the namce of the (only) user account.

This had a 'no entry' symbol.

Solution: RH click on folder with no entry symbol. Get Info. Sharing and Permissions (at the bottom). Click padlock to edit. Plus symbol - add the User account. Change privilege to 'Read & Write'.


After this, 'Enter Time Machine' opened the TM visualiser as normal. Panic over.

share|improve this answer

AJ Slater's answer did it for me. Mine is a kind of strange setup of an NTFS external drive with a sparsebundle image. In this case I had to open the sparsebundle image and link to the .backupdb directory like this:

cd /Volumens/NTFS_EXT_DISK
ln -s /Volumes/TM-backup-of-javiers-MacBook-Air/Backups.backupdb .

The TM-backup-of-javiers-MacBook-Air is the sparsebundle that is on the root directory of my NTFS drive and that I had to previously mount in order to do the linking.

After that I entered the precious star field of TimeMachine.

share|improve this answer

Just for the completeness seck , I would like to add this answer here.

I had a 500GB 2nd generation TC and i recently upgraded to 4th Gen 2TB TC .

Coincidentally i gave exactly same name to new capsule along with its new Hard drive as that of the older one. Then( i mistakenly ) added their passwords to my keychain.. VIOLA..

I had intermittently been able to either back up and get into time machine mode. Some times it used to get stuck in the while trying to find a backup drive.

I fixed it with :

  1. first removing all the entries form my keychain.
  2. Re-selecting the backup drive from time machine preferences.
  3. Re-adding the "remote Drive mouting" from my Preferences->Users & Groups -> Login Items
share|improve this answer

I found that simply turning off Time Machine in System Preferences and then turning it back on again worked. :-)

share|improve this answer

You should enable local storage by Time Machine. Just run the following command in Terminal:

sudo tmutil enablelocal
share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

This enables the local TM cache/backup. How does this help the OP? – patrix Oct 24 '13 at 13:56

I was having the exact same problem in Capitan as well. My screen would try and go to time machine but would give up and revert to the original screen. Found a hint on another forum and apparently, it could be related to a dual screen. When I unplugged my Thunderbolt display and tried it from my laptop alone, it worked fine. Hope that helps some of the people!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.