Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've never used @me.com or @mac.com emails before. Neither did I use MobileMe.

So when the iCloud came out last night I created @me.com email account this morning. Registration on its own went just fine. Email account was added to Mail.app.

Questions:

  1. How to setup SMTP as Sending emails doesn't work?
    • In the iCloud email account settings the SMTP account is set to iCloud (iCloud) which occasionally is displayed as iCloud (iCloud, Offline) - this has been set by the iCloud config when creating the @me.com account
    • The above iCloud SMTP is not listed in the SMTP servers list
    • Connection Doctor doesn't check the outgoing iCloud setting either - just as if it didn't exist.
    • According to Apple's KnowledgeBase on iCloud Email the SMTP server is smtp.mail.me.com, but Mail.app reports an invalid SSL certificate
  2. What would be IMAP settings for the new @me.com accounts?
    • Mainly asking because the settings iCloud config set are not all filled in and are not following the earlier linked support document, e.g.:
      • username is the <username>@me.com, not the full address
      • incoming mail server is p06-imap.mail.me.com and it is grayed out
      • password field is empty
    • Receiving emails does work though, not sure why

So, any tips on getting the @me.com working properly? All other iCloud services seem to work fine.


Edit

It seems to have started working for me without any tweaks. I simply had it disabled for last couple of days, enabled now and it started working without any intervention on my side.

share|improve this question
1  
You can get server details here: support.apple.com/kb/HT4864 As for Connection Doctor not checking the SMTP server when iCloud is setup automatically, that is expected behavior. You can monitor the system's status here: apple.com/support/icloud/systemstatus –  cksum Oct 13 '11 at 10:11
    
As I said. Settings specified in the KnowledgeBase contain SMTP server that doesn't validates against SSL, so I'm not entirely happy using it until it does. With regards to the systemstatus page - well, it doesn't say anything about STMP being down at any time now or recently. But I did notice that I'm not the only one having such problems using SMTP. –  Michal M Oct 13 '11 at 11:05
    
Ahh, I see up there you tried this. I'd wait. I don't think it has anything to do with you, but rather Apple's servers. Let OS X configure the account automatically and give it time. As of writing this, my email can't connect. Apple released a TON of stuff today. Their servers are likely being hammered. Just give it a bit. –  cksum Oct 13 '11 at 11:49
    
Having this problem as well - anyone getting anywhere? –  jrtc27 Oct 13 '11 at 20:15
    
Nope, not yet. I guess we can blame early adoption days for this, but that's hardly an excuse. –  Michal M Oct 13 '11 at 20:25

5 Answers 5

Not sure if this helps but been a mobile me user for a year now and this is my outlook 2007 settings:

Also worth noting I have seen in small print that iCloud will only work with Outlook 2007 & 2010

Account type: imap

Incoming mail server: mail.me.com

Outgoing mail server: smtp.me.com

  • (I note that Apple's KB of this states: smtp.mail.me.com i.e. mine does not have "mail" in it).

User name: (_ _ _ _ _)@me.com (don't put in @me.com though)

Tick require logon using SPA

on advanced tab:

outgoing server tab

my outgoing server (SMTP) requires authentication: tick this

use same settings as my incoming mail server: click this

Advanced tab

Incoming server (IMAP): 993

Use following type of encrypted connection: SSL

Outgoing server (SMTP): 587

Use following type of encrypted connection: TLS

So far my account is still working but have not upgraded to iOS5 or iCloud yet as waiting for update to another program that I use to bypass iTunes for music importing.

share|improve this answer
up vote 0 down vote accepted

Since nobody really put that as an answer I'd do it myself.

The answer is to simply wait. iCloud is at its infancy and is being accessed by potentially millions of customers so it may not work properly yet. Give it some time and things should work normally in couple of days. For me it was 5.

share|improve this answer

As noted by Michal M above, the outgoing mail server (smtp.mail.me.com) does not talk SSL, but it does apparently talk TLS, which is apparently as secure as SSL (see http://luxsci.com/blog/ssl-versus-tls-whats-the-difference.html). After unchecking the "Use SSL" box on the Advanced tab for the outgoing mail server in Apple's Mail.app, I am able to send mail from my @me account using the Mail.app.

I've seen other posts on other boards that said smtp.mail.me.com talked TLS. I've been away from network stuff for a while, but when I have the "Use SSL" box checked, the "Connection Doctor" in Apple's Mail.app shows the following as the last attempted communications with smtp.mail.me.com before it tells me it can't send the message:

WROTE Oct 25 13:38:06.435 [kCFStreamSocketSecurityLevelNone] -- host:smtp.mail.me.com -- port:587 -- socket:0xbc912f0 -- thread:0xbc26770 STARTTLS

READ Oct 25 13:38:06.562 [kCFStreamSocketSecurityLevelNone] -- host:smtp.mail.me.com -- port:587 -- socket:0xbc912f0 -- thread:0xbc26770 220 2.5.0 Go ahead with TLS negotiation.

I suspect it hangs there because Mail.app wants to use SSL (on top of the request to STARTTLS?), and smtp.mail.me.com wants to use TLS (only?).

I don't know the best way to get Apple to update their KnowledgeBase document (http://support.apple.com/kb/HT4864), which clearly says the "use SSL" box should be checked.

share|improve this answer

Interestingly I had a similar problem last night, and I have been using iCloud for some time now. I suspect it was caused by the live switch on iCloud. I simply went to the iCloud preference panel, logged out and logged back in. The new terms and conditions was shown, I accepted, restarted Mail and everything was working.

I suggest trying this first, because manually configuring it can cause problems in future should Apple decide to make changes to the routes.

The IMAP setting for iCloud is available in this Apple support document.

share|improve this answer
    
Unfortunately didn't help. I did have to accept the T&Cs initially though. It doesn't ask for it now. Logging in/out from iCloud changes nothing. Nor does enabling/disabling Mail sync in iCloud prefPane. –  Michal M Oct 13 '11 at 7:40
    
iCloud.com is blocked at work so I can't confirm if there is a document explaining how to set it up from Apple yet. The preference pane has been the only way I've done it now. However, when logged into iCloud, if I recall, the configuration is available under your account settings/advanced, or used to be. –  Diago Oct 13 '11 at 7:48
    
Nope, can't see anything like that :( –  Michal M Oct 13 '11 at 8:01

if you want to use Pine or Alpine as a mail client, you have some problems. Here are the correct datas for using iCloud and pine oder every other smtp / imap service.

http://teleschirm.info/150/220/alpine-pine-konfiguration-mit-apple-icloud-mail/#pinerc_config

share|improve this answer
    
Welcome to Ask Different! While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  grgarside Oct 14 at 18:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.