Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Possible Duplicate:
How can I prevent SMS messages from being shown on the iPhone lock screen?

I am aware that the text message preview can be disabled so that the actual message is not displayed. However, there is still an alert that a text has been received and from whom that can be openly seen on the lock screen. Therefore full privacy is compromised.

Can I disable this alert completely on the iPhone 4?

Thank you

share|improve this question
    
Just to be clear, I am aware that I can go to Settings/Messages and disable "Show Preview". Doing so will prevent the actual SMS message text itself from displaying on the lock screen as a "preview". This is the answer given to another similar question. However, an alert still appears with the sender's name which can be seen by anyone on the lock screen. For complete privacy I want to prevent this. Thank you. –  Driver256 Oct 12 '11 at 3:39
    
If you are using iOS 4, then you cannot. You can disable a preview of the message (Settings > Messages) but cannot completely remove it from the Lock Screen. Refer to the above steps for iOS 5. –  cksum Oct 12 '11 at 3:41
    
Thank you, yes I am using iOS 4. I appreciate your prompt action and very helpful, on point, answer. Please note that my question is not an exact duplicate of the other question, not at all. Thank you again. –  Driver256 Oct 12 '11 at 3:46
    
Can't wait for iOS 5 -- yay! –  Driver256 Oct 12 '11 at 3:46
    
One more day. I've edited the title but will leave it closed seeing as it won't be a problem for you come tomorrow. I'll leave it to a site op's discretion if they want to reopen it. –  cksum Oct 12 '11 at 3:49
show 2 more comments

marked as duplicate by cksum, bmike, Nathan Greenstein Oct 12 '11 at 3:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

Go to Settings. Then Notifications. Then Messages from the list. There you'll see several options. One of them being "View in Lock Screen." Set that to "off."

share|improve this answer
    
Thank you for the answer, however, there is no "messages" options in the settings/notifications dialog on my iPhone 4. There is a master toggle at the top to turn all notifications on/off and a list of apps. Messages is not one of those apps. –  Driver256 Oct 12 '11 at 3:29
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.