Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a Mid 2010 MPB, running 10.7.1.

Ever since I upgraded to Lion, I have noticed that wifi connections that require 802.1x authentication are dropping whenever I lock the screen. The connections remain down until I unlock, at which point they quickly start passing traffic again.

This behavior is new as of 10.7.

As I mentioned earlier, this only applies to 802.1x connections. Unencrypted Wifi and non-802.1x connections are not affected. My guess is that the keychain is de-authenticating my 802.1x session when I lock the machine and then re-authenticating when I unlock.

Do you know of any way to prevent this behavior?


Edit: I'm using username/password auth for 802.1x, not certificate auth.

share|improve this question

4 Answers 4

I had this exact problem, and I was pretty annoyed by it. I stopped "locking" my screen, and instead started "sleeping" display. The wifi stays connected when screen is asleep. I assigned "Sleep Display" to a hotkey using BetterTouchTool (http://blog.boastr.net/).

Then, I went to System Preferences > Security > Require Password after sleep or screensaver begins.

Now my hotkey puts my display to sleep, and then the computer requires password when I wake it up. So it's the same functionality of Locking my computer without losing wifi.

share|improve this answer

If you open up Keychain Access, go to Preferences..., and then click on the First Aid tab, is everything checked? There is an option to keep the Keychain unlocked there. Perhaps that's the option you need?

share|improve this answer

In MacOS, I see 2 model "lock"

_Login Windows: this model actived, may be drop connection

_Just Lock: lock screen and not dtop connection

To access lock method you want, you can install "Lock Me Now" on AppStore, it's free.

share|improve this answer

If you're using a .cer certificate to authenticate, can you add it to the system keychain and set it to always trust?

share|improve this answer
    
I should have mentioned - I'm using user/pass auth for 802.1x, not certificate auth. I've edited my question to include this information. –  EEAA Oct 6 '11 at 21:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.