Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I constantly get this warning in Matlab, which I run on the command line:

This process is attempting to exclude an item from Time Machine by path without administrator privileges. This is not supported.

What can I do to prevent this?

share|improve this question
    
What part of your code is trying to alter Time Machine information? –  Mark Oct 4 '11 at 16:21
    
no part at all... Matlab just starts spitting out this warning, even with me doing nothing –  romeovs Oct 4 '11 at 16:50
add comment

3 Answers 3

up vote 1 down vote accepted

Start Matlab as administrative user once so it can do the exclusion.

share|improve this answer
add comment

It is reported here, they claimed that the issue is for all version of Matlab on Mac OS X Lion. So I guess you could simply use sudo to get this problem done. And wait with more patient for a fix.

share|improve this answer
add comment

Running sudo matlab once worked for me. This assumes that /Applications/MATLAB_R20???.app/bin has been added to PATH.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.