Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

enter image description here

I don't the the exact reason why, but all the files in my home directory have 0620 file permission. What I remember is that I setup file sharing in System Preference.

enter image description here

Now, when I try to delete file in my home directory, this dialog box pops up to ask the password. I modified all the files back to permission 0774, but I still can't delete the file without answering the password.

What went wrong? How can I get the system back to normal? I use Mac OS X Lion 10.7.2.

ADDED

Refer to this post also

share|improve this question

1 Answer 1

You must set the permissions of the folder the files are in as well.

share|improve this answer
    
Which means going up to the /Users folder and setting 0774 'apply to enclosed items' –  Digitalchild Oct 4 '11 at 6:09
    
'apply to enclosed items' is dangerous, as it wipes out the existing permissions -- especially when the permissions you're applying are something weird like 774 (that's probably not what you want on anything, let alone everything). –  Gordon Davisson Nov 5 '11 at 4:58
    
@Lyken No, this is not the idea. Changing the permissions on folder itself (without recursing down) should be enough for the problem described. –  patrix Nov 5 '11 at 11:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.