Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I set up a shortcut in System Preferences → Keyboard → Keyboard Shortcuts:

But it doesn't work. What's wrong?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Add it as a global shortcut (under All Applications, not System Preferences), and include an ellipsis in the menu name (either ... or .):

The only apps this method works for are System Preferences, System Information, and App Store. For others, see:

share|improve this answer
    
thank you, that works great. –  gilzero Oct 2 '11 at 5:49
    
Note that for any particular menu item that appears with three trailing dots, exactly one of either ... or is correct, and the other will not work. –  Daniel Lawson Dec 9 '11 at 14:21
    
@Daniel Are you sure, and based on what? I've found that ... can be always substituted for and vice versa. –  ؘؘؘ Dec 9 '11 at 14:48
    
I'm not sure, but it is the result of my experimentation. Just to reconfirm, after you posted 26 minutes ago, I tried creating a keyboard shortcut for System Preferences… and it doesn't launch System Preferences, but System Preferences... does. –  Daniel Lawson Dec 9 '11 at 15:18

When you add a keyboard shortcut and list it for a particular application, the key binding only applies when that application is active. Thus, if you made Control-Shift-Z a shortcut for Zoom and applied that to Safari, that would mean that in Safari, and only in Safari, pressing Control-Shift-Z would zoom (i.e. same as clicking the the green button in the upper left hand corner of the window). Binding keyboard shortcuts to particular applications usually makes sense because each application has its own set of menu commands.

In your particular case, creating a key binding to launch System Preferences and binding it to System Preferences is guaranteed to never do what you want, because the only time it would launch System Preferences would be when System Preferences is already the active application.

The fix is to insert System Preferences... (with three periods, not an ellipse) as a shortcut in the All Applications section.

enter image description here

share|improve this answer
    
Why does adding "..." makes it work? –  Marlon Dec 9 '11 at 7:28
    
The text in the "Menu Title" box has to exactly match the text of the menu item you want to select. In the case of the "System Preferences..." menu item, the menu text isn't "System Preferences"; it's "System Preferences...". –  Daniel Lawson Dec 9 '11 at 13:04
    
got it, didn't realize that you were talking about application shortcuts as opposed to a service to be used as a global shortcut. Thank you. –  Marlon Dec 9 '11 at 19:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.