Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Mac Mini running Mac OS X 10.6.4 which has Parental Controls enabled for an account, but with Website Restrictions set to 'Allow unrestricted access to websites'.

However, there is one website (which I cannot specify for confidentiality reasons) which does not load at all. Instead I get the following error message in the system log every time I try to access the website:

sandboxd[12606] <Notice>: webfilterproxyd(712) deny network-inbound

Obviously is the machine's IP address and 49757 in this case would be the port that the request was sent from.

The website in question is in no way a bad/inappropriate/illegal website, so I don't see why it would be filtered.

Disabling Parental Controls completely for this account fixes the problem, but I'd rather not do that.

Any idea how I can fix this, or why it is happening in the first place?

share|improve this question

In case someone else stumbles on this as I did...

Deleting webcontentfilter.kext is actually deleting part of Parental Controls. kext is short for kernel extension. It is better to turn Parental Controls off than to wreck it.

What was probably going on is that you need to, in the main firewall (under Security, in System Preferences), allow incoming connections from that IP address. You may need to configure the firewall manually, if so, consult a complete tutorial.

Also, 49757 is not the port the request was coming from, it is the local port the request is attempting to connect to.

share|improve this answer
up vote 0 down vote accepted

Turns out it can be solved by doing:

sudo rm -rf /System/Library/Extensions/webcontentfilter.kext/

This might cause a few errors in the system log but appears to work fine for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.