Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Hoping someone can help me figure out this problem. I have a Dell ST2410 display hooked up to my Mac mini via the mini display port hooked up to a DVI adapter and then DVI in on the display. The problem is that the display enters "Power Save Mode" when Display Sleep (in Energy Saver prefs) activates. When this happens, the display loses the connection to the Mini and when I wake it up the screen is just static until I turn the display off and then back on. This happens even though I have set the input to DVI on the display. The only instructions I've found to disable Power Save Mode on the display require it to be hooked up to a PC so you can change the option in Windows Control Panel/ Power Options. I do not have a PC to do this with, nor do I have BootCamp set up.

Is there any way to disable this annoying mode with my Mac? I have VMWare running XP for those rare occasions when I need to use Windows for something, but virtual machine settings don't work on the actual physical display. Very frustrating.

Specifically, I'm wondering whether there is any other way using OS X to send whatever command Windows Power Options sends to the display and turn this option off.

share|improve this question
    
What version of Mac OS X are you using? Are you using an Apple mini display port to DVI adapter goo.gl/5jzY or some third-party product? –  Wheat Williams Sep 30 '11 at 18:32
    
And which version of the Mac mini do you have? –  Wheat Williams Sep 30 '11 at 18:36
    
I think your adapter may be to blame. I'm using the same display with my iMac connected with Mini DisplayPort -> VGA and I don't have this problem –  Nathan Greenstein Sep 30 '11 at 22:51
    
I am using a mini DVI port to DVI adapter and running Lion. However, the problem existed under Leopard and Snow Leopard as well. In a PC troubleshooting forum, it said to disable Power Save Mode on the display, but this option can only be accessed by running Windows. I don't have any VGA cables or adapters to try Nathan's way of connecting the display. I may try getting a mini display port to DVI adapter to see if that helps. –  Michael Oct 19 '11 at 15:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.