Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After having upgraded from Snow Leopard to Lion on my iMac and MacBook Pro, how can I get "Internet Sharing" to work automatically as it did in Snow Leopard? In particular, my iMac gets its internet via a DSL Ethernet connection, and I have enabled internet sharing on it. While my MacBook Pro can see, via wifi, the iMac, every time I awaken the MacBook Pro from sleep, I have to manually select the iMac from the list of available wifi sources and manually re-enter the password.

To attempt to get things to work, I removed the preferred wifi network and then added it back in. I made sure I checked the box that said “Remember networks this computer has joined” in the general preference pane section and also I made sure I checked the box that said “Remember this network” in the specific dialog box for logging in to my iMac-provided network. However, despite, that, when I did the test of putting the MacBook Pro to sleep and awakening it, I still had to manually select my iMac-provided network and provide the password.

share|improve this question

1 Answer 1

Under Network on the system preferences, in on the wireless pane on the macbook pro, you should see Preferred Networks. Make sure the iMacs network is on top and all the require administrator authorization to: are unchecked.

share|improve this answer
    
thanks for your reply; I did what you suggested in your recent posting, but for some reason, the MacBook Pro still does not remember the network. When I sleep the MacBook Pro (while it is connected to the preferred network supplied by the iMac) and re-awaken it, the message "None of your preferred networks are available" appears, and I am presented with a list of available networks to choose from, one of which is the iMac, so I need to log in again. –  Richard Fuhr Sep 27 '11 at 18:23
    
Just wondering, Have you updated to 10.7.1? There were many people that had that same issue that was resolved with updating. Another question is on the main network page near the top is Location: is this set to Automatic? –  utahwithak Sep 27 '11 at 18:30
    
You can try clearing the dns cache from the terminal using dscacheutil -flushcache –  utahwithak Sep 27 '11 at 18:33
    
I checked and both my iMac and my MacBook Pro are running 10.7.1 and my Location is set to Automatic. –  Richard Fuhr Sep 27 '11 at 18:35
    
Invoked dscacheutil -flushcache but still am having the same symptoms of needing to connect manually after sleeping the MacBook Pro. One other possible issue; have any users reported that the name of the network to which to connect must be one word, without blank spaces? –  Richard Fuhr Sep 27 '11 at 19:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.