Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an account on dreamhost that autoforwards everything on to my GMail. This is fine as it all gets pulled into my phone, but if I try to reply on my iPhone, it shows the google address, not the fancy forwarded address.

To fix this I attempted to add the forwarded account via IMAP to my phone, fixing the problem, and introducing a second. Now I have duplicates of emails one for GMail and one for the original account. What'smore, spam sent to the fancy email is not being filtered, so I'm getting both duplicates of normal emails, and unfiltered spam.

What I'd like is to set my iPhone so it can send from that account, but either does not check for emails, or cannot check for emails.

In the past I've set my phone up to use the 'from' trick, which has almost worked ( users can still tell it's not quite from that address though it gives the illusion ), and the instructions fail when applied to iOS5 ( impending death of the trick? )

share|improve this question
add comment

3 Answers

I have a similar set up. I use mBox Mail to handle Hotmail. I wanted a send-only account so I can use the iPhone integrated e-mail features (eg. e-mail this photo.)

  1. Find the correct e-mail settings from your e-mail provider.
  2. Open Settings, Mail Contacts Calendars, Add Account..., Other, Add Mail Account.
  3. Set the following settings.

    Name: Your Name
    Address: your.address@provider.com
    Password: YourPassword
    Description: E-mail Provider (send only)

  4. Press Next.

  5. Set the following settings:

    IMAP/POP: as required

    Account Information
    Name: Your Name
    Address: your.address@provider.com
    Description: E-mail Provider (send only)

    Incoming Mail Server
    Host Name: mail.provider.com
    User Name: YourUserName
    Password: YourPassword

    Outgoing Mail Server
    Host Name: mail.provider.com
    User Name: YourUserName
    Password: YourPassword

  6. Press Save.

  7. Now press the account you've just created and remove some information.

    Incoming Mail Server
    Host Name: (blank)
    User Name: YourUserName
    Password: (blank)

  8. Press Save.

  9. Ignore any errors you receive.
share|improve this answer
1  
These instructions are useless in iOS5. When removing those fields in the Incoming Mail server, the 'done' button is inactive, preventing progress. –  Tom J Nowell Oct 3 '11 at 14:43
    
Bugger... What if you type a fake incoming server or an incorrect password? It will try and fail, but not download your mail. –  Hand-E-Food Oct 3 '11 at 21:22
    
I thought of that and put example.com in the domain and pressed done, unfortunately the next step of the process is iOS5 verifying your settings by contacting the server and attempting a successful login. =( –  Tom J Nowell Oct 4 '11 at 9:16
    
Okay, getting convoluted now... :-) Change your email account's password to something simple, connect with your iPhone, then revert to your original password. –  Hand-E-Food Oct 4 '11 at 11:28
    
This would give me an email account that could not retrieve email yes, but it would also prevent me sending emails from that account also ( I only have 1 password field for both SMTP and IMAP on the server ) –  Tom J Nowell Oct 5 '11 at 11:14
add comment
up vote 2 down vote accepted

I have found the solution!

I set up a second email account on my server with an obscure name, then, I changed the POP/IMAP settings to use that account for receiving, and left the send/SMTP details unchanged.

This now gives me the desired behaviour. It also gives me a receive only account ( which could also be desirable ).

If you are on iOS4 or below, you can also refer to Hand-E-Food's answer. My instructions will work for iOS5 ( due to the extra checks iOS5 makes to verify what you've entered )

share|improve this answer
add comment

Got it to work!

Step 1) Create a new account on the same domain that will not receive emails. (I would assume this might work using another domain IMAP address you have proper credentials for, however, this is not what I did or tested)

Step 2) Create a new IMAP email account on iOS. Provide only the credentials of the email account you want to use for sending emails (not the account created in Step 1). Let it verify and completely setup this way.

Step 3) Alter the new IMAP email account on iOS. Change the Incoming Mail Server's User Name and Password to the account you created in Step 1. Let it verify.

Step 4) Alter your default account to this new account for sending emails in iOS.

share|improve this answer
    
This does work, but I'd already figured this out and posted the solution, sorry –  Tom J Nowell Jan 25 '12 at 10:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.