Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

How do I disable that horribly annoying dialog that tells me I am not connected to any wifi network?

None of your preferred networks are available.

Choose the Wi-Fi network you want to join from the list below.


Edit:

I use the wifi.

So why do I want the dialog gone?

  • The dialog only shows up when I have no internet connection. Great. That dialog won't magically help me know encryption keys to random networks I am around. There is only like one time that it was useful, and thats the first time I ever turned this machine on.
  • The dialog is annoying.
  • The dialog has zero uses. I can use the status bar icon to do all the needed work that the dialog provides, except I get to chose when to stop and use it, not the dialog choosing "stop what ur doing and connect to the f-ing internet"
share|improve this question
    
@Lri: Yea you were correct with the edits. Thanks. –  Dmitriy Likhten Sep 26 '11 at 17:50
    
Actually I didn't realize there was an image, Lri that is not correct, the actual image is the one that says "You have no connectivity. Actions: Diagnose Network / Join Other network", the screenshot attached is only when you click join other. –  Dmitriy Likhten Sep 28 '11 at 4:58

2 Answers 2

up vote 4 down vote accepted
+50
  • Open the Network pane of the System preferences.
  • Select AirPort in the list on the left.
  • Uncheck the “Ask to join new networks” checkbox. Ask to join new networks checkbox
  • Et voilà! :)
share|improve this answer
1  
And to avoid putting opinions in the answer itself: I totally agree this “bother me” default choice is ridiculous. It is even worse on iOS. I really hope it helps newbie users, but I'm afraid it's as annoying for them as it is for everyone. This default option makes sense, IMHO, only for desktop computers, not portable devices. –  MattiSG Jul 24 '12 at 13:39
    
Yea, I'm checking it out. What about the dialog that says "No known networks exist" which is equally as annoying. –  Dmitriy Likhten Jul 25 '12 at 13:43
    
@DmitriyLikhten Well, normally that's the one controlled by this setting :-/ Could you provide a screen capture if this doesn't solve it? –  MattiSG Jul 25 '12 at 21:26
    
Love you, bro. Hopefully 10.8 will resolve this bs by default. –  Dmitriy Likhten Jul 26 '12 at 3:45
    
@DmitriyLikhten :) –  MattiSG Jul 26 '12 at 8:49

There are two options that I could see that might work for you Uncheck ask to join new networks and try unchecking show wifi status in bar. These are options available in the Network Preferences. You could also try to set the wifi service to inactive. Click the service cog at the bottom left while the wifi service is selected.

If all else fails just turn the wifi off. I assume you aren't using it since you want to disable the warnings and you know its not connected.

share|improve this answer
    
Good answer! But I think he still wants to be able to use wifi, and to access it from his status bar. I think the only option he needs to change is "Ask to join Networks". Mac OS will stop asking you to choose a network and will just go with what it finds. –  kevin9794 Sep 24 '11 at 3:34
1  
It would be my first option as well I just assume he isn't using wifi since he knows its not connected and doesn't want messages from it. It would help to know what options he has checked. –  Kyle McElyea Sep 24 '11 at 16:35
1  
@kevin9794: You hit the nail on the head with that comment. That dialog is a) unneeded b) really annoying and c) serves ABSOLUTELY NO PURPOSE. It only shows up when I'm not home because there is obviously no networks available. –  Dmitriy Likhten Sep 24 '11 at 21:56
1  
curious as to why I get a -1 when I stated the correct option as my first option to try? –  Kyle McElyea Sep 25 '11 at 15:39
    
shrug wasent me. I only give -1s when the post is off topic and not helpful whatsoever. –  Dmitriy Likhten Sep 26 '11 at 17:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.